XML Sitemaps Generator

Author Topic: Configuring in easier words  (Read 1602663 times)

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #15 on: December 20, 2007, 01:09:30 AM »
Hello,

please try to manually set your server's IP address in config.inc.php file:
'xs_ipconnection' => 'xx.xx.xx.xx'

replace xx.xx.xx.xx with your server's IP. If it doesn't work, try 127.0.0.1 as IP.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jmacek07

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Configuring in easier words
« Reply #16 on: December 20, 2007, 02:13:41 PM »
Same problem...Can I just pay you the extra $10 and
have you get this done for me...I've already spent more
than $10 of my time working on it.

jmacek07

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Configuring in easier words
« Reply #17 on: December 20, 2007, 10:03:29 PM »
Ok, so I think I've fixed the last problem.  I did pay my $10 so
it'd be great to get some help.  I am now having an error:

Sitemap file is not writable: [external links are visible to admins only]

I went in and changed both the sitemap and the ror to
666  I am running a linux server so I'm not sure if that
matters one way or other.  Please help as I'd like to get this
project done!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #18 on: December 21, 2007, 05:53:53 AM »
Hello,

replied to you via email.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

paul17

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Crawler won't start
« Reply #19 on: January 22, 2008, 09:09:33 PM »
I can't seem to find the answer to my problem anywhere else in the forums.
Every time I try to run the crawler, it immediately gives me "Error opening socket to [external links are visible to admins only]".  I'm pretty sure I've installed it correctly.  The generator folder is uploaded to my main directory, I've created sitemap.xml and ror.xml, changed their permissions to 666, and changed the permissions on the data folder to 777.  The only thing I really don't understand on the configuration page is the default for "Save sitemap as" was /nfs/cust/0/89/03/630980/web/sitemap.xml.  I've tried changing it [external links are visible to admins only] and just /sitemap.xml.  I've also tried setting the maximum pages, maximum depth level, and maximum execution time under crawler limitations all to 0, 1000, 999999, and blank, but no matter what I try, I keep getting the same error message.

Another thing I don't quite understand is the importance of the public_html directory.  I've never seen or heard of this before, and at first I just put the generator on my main root directory.  I've tried creating a folder called public_html on my root directory ([external links are visible to admins only]), and putting just the generator folder and the xml files in it, and then putting the whole site in it.  I have a feeling I'm misunderstanding the basic concept of a public_html directory, but it doesn't really seem to me like it'd be that important.

Is there anything I might be overlooking?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #20 on: January 22, 2008, 10:32:37 PM »
Hello,

1. please try to enter your server's IP address in Advanced options (click
  • to expand those settings).


2. you should not *create* public_html folder, it's just how the main domain folder is often called. You should create "generator" (or other) folder in your *domain root* and upload the files into it.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

paul17

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Configuring in easier words
« Reply #21 on: January 22, 2008, 11:52:21 PM »
I feel kinda retarded for not having seen the field for IP address already, but alas, I put it in, and still get the same result.
« Last Edit: January 23, 2008, 12:01:34 AM by paul17 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #22 on: January 23, 2008, 09:55:59 PM »
Hello,

could you please PM me your generator URL?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

dan14

  • Registered Customer
  • Approved member
  • *
  • Posts: 1
Re: Configuring in easier words
« Reply #23 on: June 19, 2008, 01:41:09 PM »
Hi,

Can you please help me with the configuration - why doesn't the download come with a file explaining it?

Anyway, I keep getting this error message:

An Error Occured: The was an error while retrieving the url specified: [external links are visible to admins only]/
Error Message: Error opening socket to [external links are visible to admins only]
HTTP headers follow:

HHTP

I am operating a windows server with IIS

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #24 on: June 19, 2008, 03:43:46 PM »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jelices

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Configuring in easier words
« Reply #25 on: September 23, 2008, 11:58:41 AM »
Hello,

  I have just installed and configured the stand alone version and when I press "Run" under the Crawling menu, I get the following:

Links depth: 1
Current page: /
Pages added to sitemap: 1
Pages scanned: 1 (76.3 KB)
Pages left: 60 (+ 0 queued for the next depth level)
Time passed: 0:03
Time left: 3:37
Memory usage: 776.0 Kb

  I have left it running for a while and it does not get past that.

  Any idea what I may be doing wrong?

  Thank you.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #26 on: September 24, 2008, 08:35:53 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

bela

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Configuring in easier words
« Reply #27 on: December 29, 2008, 10:42:36 PM »
Hello,

please try to manually set your server's IP address in config.inc.php file:
'xs_ipconnection' => 'xx.xx.xx.xx'

replace xx.xx.xx.xx with your server's IP. If it doesn't work, try 127.0.0.1 as IP.
what if you're on a shared server, will using the ip adress of 127.0.0.1 cause a few problems ?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 9552
Re: Configuring in easier words
« Reply #28 on: December 31, 2008, 12:44:56 AM »
Depending on server configuration "127.0.0.1" might work, that should not cause issues.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

abonki

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Configuring in easier words
« Reply #29 on: April 17, 2009, 06:50:57 AM »
Hello,

Many thanks for the installation through Oleg and the team.
In the mail you told me
it looks like your server configuration doesn't allow to run the script
long enough to create full sitemap. Please try to increase memory_limit
and max_execution_time settings in php configuration at your host
(php.ini file) or contact hosting support regarding this

I can edit the php.ini.
At the moment the max_execution-time is 10 and memory_limit is 32M.
What numerical value is recommended?

Many Thanks in advance
Annett

 

SMF 2.0.7 | SMF © 2011, Simple Machines
XHTML RSS WAP2