Problem on Crawling ... Help
« on: July 24, 2007, 09:57:06 PM »
hi. i have a problem on the crawling, i got the follwing message...Please help

Please wait. Sitemap generation in progress...

 Internet Explorer cannot display the webpage
   Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.
   What you can try:
     Diagnose Connection Problems 
     More information

This problem can be caused by a variety of issues, including:

Internet connectivity has been lost.
The website is temporarily unavailable.
The Domain Name Server (DNS) is not reachable.
The Domain Name Server (DNS) does not have a listing for the website's domain.
If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

For offline users

You can still view subscribed feeds and some recently viewed webpages.
To view subscribed feeds

Click the Favorites Center button , click Feeds, and then click the feed you want to view.

To view recently visited webpages (might not work on all pages)

Click Tools , and then click Work Offline.
Click the Favorites Center button , click History, and then click the page you want to view.

Re: Problem on Crawling ... Help
« Reply #1 on: July 24, 2007, 10:12:50 PM »

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Re: Problem on Crawling ... Help
« Reply #2 on: August 30, 2007, 11:38:24 AM »

I have the same problem as the above. My php.ini settings allow for 5000 seconds of execution time and 32megs of script. Do you recommend I increase these settings?. I've created a larger sitemap before (150,000 pages) using a pervious version of xml-sitemaps but this time it seems to have gotten perhaps just over 100,000 pages and now i cannot access the crawing page. I get the same error as above in Internet Explorer and in Firefox it asks me to download index.php, upon opening i'm presented with a blank page.

In opera I simply get a blank page when clicking on crawling yet all other pages seem to work. I have replaced the index.php and all /pages files but I still cannot access the crawing page.

I own the server I am operating xml sitemaps on and see no problems there and as mentioned before I've been able to create larger sitemaps using xml-sitemaps. One thing to note is that I recently change the sitemap generator to v2.6.

Any help will be greatly appreciated.

Re: Problem on Crawling ... Help
« Reply #3 on: August 30, 2007, 06:14:30 PM »

I would suggest to increase memory_limit setting only, you can keep max_execution_time unchanged.
Re: Problem on Crawling ... Help
« Reply #4 on: August 30, 2007, 10:30:39 PM »
Hello Again,

I have changed the max script size to 500M and just to be sure I also changed the max execution time but neither of these worked.

I reset the sitemap generator completly and began another sitemap generation, it got to around the same as last time which I estimate to be around 85,000 pages. This certainly seems like a max execution time or max script size but surely 500M and 50000s execution time would be enough?

This has definatly come with the new update to v2.6 as I never encountered this problem with the previous version and unfortunatly I cannot get hold of v2.4 again.  :-[

Any suggestions?

Re: Problem on Crawling ... Help
« Reply #5 on: August 31, 2007, 12:46:36 AM »

do you have SSH access to your host? Please try to execute sitemap generator in command line.
Re: Problem on Crawling ... Help
« Reply #6 on: October 19, 2007, 05:31:32 PM »
I have the same problem.

I have tried all of the above.

I have logged into SSH as root and located the runcrawl.php file but I don't know the command to execute the file. Simply inputting in the line including runcrawl.php doesn't seem to work as I get the errors:

/var/www/vhosts/domain/httpdocs/generator/runcrawl.php: line 1: ?php:                         
Datei oder Verzeichnis nicht gefunden
/var/www/vhosts/domain/httpdocs/generator/runcrawl.php: line 2: syntax                         
 error near unexpected token `base64_decode'
/var/www/vhosts/domain/httpdocs/generator/runcrawl.php: line 2: `eval(                         base64_decode('Pz48P3BocAokb3AgPSAkX1JFUVVFU1RbJ29wJ10gPSAnY3Jhd2xwcm9jJzsKJGZUc                         lZlREpRRlU4X1oxayA9IHRydWU7CmNoZGlyKGRpcm5hbWUoX19GSUxFX18pKTsKJF9SRVFVRVNUWydiZ                         yddID0gdHJ1ZTsKJF9SRVFVRVNUWydyZXN1bWUnXSA9IHRydWU7CmluY2x1ZGUgJy4vaW5kZXgucGhwJ                         'sKPz4='));

By using the wget command i've been able to run the script but to no avail, it simply stalls at almost exactly the same figures as other people have posted....and like others the previous version worked fine.

Any help on this would be greatly appreciated, even if I could just get the previous version again as that worked fine.