Fatal Error
« on: September 24, 2010, 08:27:23 PM »
Sorry to open a topic with an issue there is in many other topics, but I wen't through them all, tried a lot of things, and had no success.

The error is:

Links depth: 5
Current page: forum/index.php?showtopic=88039&pid=459168&mode=threaded&start=
Pages added to sitemap: 15698
Pages scanned: 17220 (1,015,325.8 KB)
Pages left: 12590 (+ 49469 queued for the next depth level)
Time passed: 0:56:19
Time left: 0:41:10
Memory usage: 142,718.8 Kb
Auto-restart monitoring: Fri Sep 24 2010 16:23:18 GMT-0300 (E. South America Standard Time) (41 second(s) since last update) Resuming the last session (last updated: 2010-09-24 14:38:47)
Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 27767563 bytes) in /home/ueba.com.br/public_html/sitemapgen/pages/class.utils.inc.php(3) : eval()'d code on line 27

So far I've done this:

1. tried to raise the script memory limit through: ini_set("memory_limit","512M");
2. tried to raise the php memory limit through .htaccess
3. I've raised php memory limit through php.ini (I do have root)

So far none of these have worked. Could you please help me out here?


Re: Fatal Error
« Reply #1 on: September 24, 2010, 08:53:45 PM »

please let me know your generator URL/login in private message to check this.
I would need to customize exclusion/do not parse settings to improve crawling speed.
Re: Fatal Error
« Reply #2 on: October 27, 2010, 05:36:40 PM »
I too am having this exact same error message.
I am running the software on XAMPP locally and it worked for hours and hours until that message appeared.  I see I shouldn't mess with the settings but how should I proceed?

Thanks in advance.
Re: Fatal Error
« Reply #3 on: October 27, 2010, 05:45:33 PM »

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration  (php.ini file)
Re: Fatal Error
« Reply #4 on: October 27, 2010, 05:53:58 PM »
Sorry to be a pain, but could you be more specific?  can you walk me through that and how much do i increase it?
Re: Fatal Error
« Reply #5 on: October 28, 2010, 06:41:45 PM »
Exact settings depend on the size of the site, you can try this:
memory_limit = 512M
max_execution_time = 9000
Re: Fatal Error
« Reply #6 on: November 02, 2010, 03:16:40 PM »
So I edited php.ini as you recommended. 

It went along for a while and now again, I get this.

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20591725 bytes) in C:\xampp\htdocs\generator\pages\class.utils.inc.php(2) : eval()'d code on line 27

I just want my sitemap completed, how do set it to unlimited time and memory.