Now I'm getting this message.
« on: March 25, 2022, 03:27:01 AM »
There was an error while retrieving the URL specified: (my website)
HTTP Code:

HTTP headers:
x_csize: 0     << What does that mean?  :police:

HTTP output:

I have a couple of web sites running PIWIGO gallery software, both sites on same Apache web server, Ubuntu 20.04 server, php 7.4 ...

Both sites have identical setup for headers, vhosts, ect. Site 1 runs perfectly from the interface BUT site 2 dies with the x_csize: 0 message.   I tried with curl on and curl off, with curl off I had a totally different failure.

However, I can successfully create Site 2 sitemaps if I run from command line or cron, only the interface dies with that message.

But when I ran it from the command line as a test, I was getting pages and pages of warning messages about "declared variables", (or something like that). Looks like the PHP needs a touch of TLC!
Re: Now I'm getting this message.
« Reply #1 on: March 25, 2022, 04:35:31 AM »
Probably there is a configuration problem - it looks like your server doesn't allow local network connections via port 80 (http) or 443 (https) - as a result sitemap generator is not able to crawl the site. This is usually related to firewall installed at the host - could you please contact your hosting support regarding this?