XML Sitemaps Generator

Author Topic: Sitemap was not generated yet, please go to Crawling page to start crawler manua  (Read 20291 times)

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
I think I've installed it correctly, however when I go to;-
[external links are visible to admins only] and click 'Run' the page changes and some sort of text rushes across the screen, then before you have a chance to read anything, the page goes to the configuration page. On the left-hand side of the config page it says;-
Sitemap was not generated yet, please go to Crawling page to start crawler manually or to setup a cron job.
However in the browser address bar it says;-
[external links are visible to admins only]

So... what's the likely cause please?

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
I think I'm about to get a reply, something to the effect of;-
Quote
Probably there is a configuration problem - it looks like your server doesn't allow local network connections via port 80 (http) - as a result sitemap generator is not able to crawl the site. This is usually related to firewall installed at the host - could you please contact your hosting support regarding this?
Sadly I thought I would get an easy to run package with a 500 page limit removed. I already know from experience my host won't be very co-operative with making changes to satisfy the most likely answer to my initial post. Therefore I have to ask what is the way forward?

Perhaps there should have been some way to test my host before I forked out for this package

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Hello,

please try to enter the IP address of your server in config.inc.php file:
'xs_ipconnection'=>'XXX.XXX.XXX.XXX'
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Thanks for your quick reply.

Been and added the IP as suggested. Now scans, and comes back with
Quote
<?xml version="1.0" encoding="UTF-8"?>
<urlset
      xmlns="[external links are visible to admins only]"
      xmlns:xsi="[external links are visible to admins only]"
      xsi:schemaLocation="
            [external links are visible to admins only]
            [external links are visible to admins only]">

<url>
  <loc>[external links are visible to admins only]</loc>
  <priority>0.50</priority>
  <lastmod>2006-10-26T02:25:26+00:00</lastmod>
  <changefreq>daily</changefreq>
</url>
</urlset>
Why has it only returned with one url when it has about 1600 to choose from?

xml-sitemaps

  • Administrator
  • Sr. Member
  • *****
  • Posts: 146
    • XML-Sitemaps.com
Looking at your previous error message there looks to be a redirect on your site. Check your config screen and start url to see if that is causing a problem. Try entering your start url including www and see if that makes a difference.
Philip Nicosia
www.xml-sitemaps.com

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Tried removing the .htaccess file as it had redirects - still returns with one url

Tried removing original index.htm file which had a redirect  if the .htaccess redirect failed - still returns with one url

Tried loading an empty .htaccess file and a 'normal' index page - still returns with one url

Any more ideas?

xml-sitemaps

  • Administrator
  • Sr. Member
  • *****
  • Posts: 146
    • XML-Sitemaps.com
Hi, could you please either email or PM the url to your sitemap generator for us to take a look at your problem please.
Philip Nicosia
www.xml-sitemaps.com

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Just so that others know how admin has progressed my problems.

Admin suggested
Quote
please try to enter IP address of your server manually in generator/config.inc.php file:
 'xs_ipconnection'=>'xxx.xxx.xx.xxx'    (IP of Just_a_blokes website)
 or
 'xs_ipconnection'=>'xxx.x.x.x'    (not sure what this IP relates to)

After entering the IP address of my website it now scans my site. However because I have a redirect at the root to a specific folder, it only scans that folder. Same as I have so many other folders

I tried removing the redirect page and the .htaccess file as there is a redirect in there as well, but it still only scans the one folder. Ill try removing them again to see what happens, but it would be nice if I didn't have to remove the files to create a fresh sitemap every time.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Hello,

for testing purposes you limit "Maximum number of pages" in Sitemap Generator configuration and see if it works for a smaller set of pages.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Hi,

I un-installed the original set-up last year, and now trying to re-install the latest download, but I'm now encountering problems again.

Carrying out a scan of my site with the free online version, it only lists two of the 500 or so pages. So downloaded the latest version to try from with-in my site. But get nothing.

I've tried [external links are visible to admins only] and [external links are visible to admins only]. I've even added  'xs_ipconnection'=>'xxx.xxx.xx.xxx', to the generator/config.inc.php file.

when clicking the crawl/run button, I get
Quote
Please wait. Sitemap generation in progress...
Links depth: -
Current page: -
Pages added to sitemap: -
Pages scanned: - (- Kb)
Pages left: - (+ - queued for the next depth level)
Time passed: -
Time left: -
Memory usage: -

Then it returns to configuration page and reports;
Quote
No sitemaps found
Sitemap was not generated yet, please go to Crawling page to start crawler manually or to setup a cron job.

Not sure where to go now?

Can anyone help me please?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Do you have your old setup as backup so that I can check your settings?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

just_a_bloke

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Following your post about the back-up, I dug out the back-up and uploaded it. Strangely it looks like its going to index the pages, however some bold text appears in the progress window, then quickly disappears before having had a chance to read it, and is covered by the output of the sites index.htm file and just hangs.

I renamed the original 'generator' folder to retain the new version on the server. On trying to run the new version in the re-named folder, it still does as originally reported in today's earlier post.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Please PM me your generator URL so that it's easier to troubleshoot.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2