XML Sitemaps Generator

Author Topic: Several bugs in v2.0  (Read 28171 times)

marc

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Several bugs in v2.0
« on: January 17, 2006, 08:49:45 PM »
In the "View sitemap" menu there are two php warnings:

Warning: gzfile(/home/.../public_html/sitemap/data/sitemap.xml.gz): failed to open stream: No such file or directory in /home/.../public_html/sitemap/pages/page-view.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 31

Warning: implode(): Bad arguments. in /home/.../public_html/sitemap/pages/page-view.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 31


In the "Configuration" menu at "Your Sitemap URL:" there is no / (slash) between [external links are visible to admins only] and sitemap.xml. It is "[external links are visible to admins only]"

Greetings,
Marc

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Several bugs in v2.0
« Reply #1 on: January 17, 2006, 08:57:45 PM »
Hello Marc,

1. Could you please try adding the trailing slash in "Starting URL" input at configuration page and recrawl?
2. Is "Warning: gzfile(..)" message still displayed after you have generated the sitemap?

edit:
Quote
In the "Configuration" menu at "Your Sitemap URL:" there is no / (slash) between http://www.domain.com and sitemap.xml. It is "http://www.domain.comsitemap.xml"
Do you mean that slash is removed after you save the options at config page?

thank you for reporting!
« Last Edit: January 17, 2006, 09:00:00 PM by admin »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Several bugs in v2.0
« Reply #2 on: January 17, 2006, 09:04:45 PM »
Please note that you should perform a new crawl with v2.0 to ensure everything is working correctly :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

marc

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Several bugs in v2.0
« Reply #3 on: January 17, 2006, 10:00:43 PM »
>> 1. Could you please try adding the trailing slash in "Starting URL" input at configuration page and recrawl?

It is no problem to correct it by hand, maybe it is just a typing error in your php source code for that input field.

>> 2. Is "Warning: gzfile(..)" message still displayed after you have generated the sitemap?

Now, everything is fine. Well done  ;D

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Several bugs in v2.0
« Reply #4 on: January 18, 2006, 01:40:51 AM »
Ah, ok. Thanks! :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2