XML Sitemaps Generator

Author Topic: Basic Q's ref a new install.  (Read 30704 times)

tekguru

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Basic Q's ref a new install.
« on: January 22, 2006, 12:27:34 AM »
Guys first of all thanks for a creating a superb system......

Well what I hope will be a superb system when I manage to get it going.

Install has gone okay, and configuration, the relevant CHMOD's have been performed and all is ready to go... (I think).

However after entering the generator and opting to run a manual crawl (with or without backgond mode set) I get the 'Please wait. Sitemap generation in progress...' message and a blank screen below it. After a fair number of minutes I get the status screen displaying:

"Action canceled
Internet Explorer was unable to link to the Web page you requested. The page might be temporarily unavailable. "


Any ideas where I may be going wrong?

The online version worked perfectly but alas the Standalone just does not to want to do anything!

Any suggestions would be appreciated.

If it helps the site is [external links are visible to admins only]

Cheers in advance!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Basic Q's ref a new install.
« Reply #1 on: January 22, 2006, 01:24:58 AM »
Hello,

perhaps this issue is related to the browser timeout. You should try to generate sitemap in this way:
1. set "save generation state" every few minutes (180 seconds, for instance) on configuration page
2. enable "run in background" when starting
3. when you get timeout message in browser, you can go to the "crawling" page and start generation again with "resume crawling" checked

PS. if you can give me access code to your generator instance in PM, I can check your other settings to make sure they are ok.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

tekguru

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Basic Q's ref a new install.
« Reply #2 on: January 22, 2006, 08:31:26 AM »
Cheers for the reply, tried that already with noi success. One PM on the way :)

TechPad

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Basic Q's ref a new install.
« Reply #3 on: March 13, 2006, 10:40:18 PM »
I am experiencing a similar issue with version 2.0.2. The config seems to be fine, file permissions all set correctly, but when I go to run the crawl manually from the GUI, I see the message "Please wait. Sitemap generation in progress..." at top and the following in the body:

Links depth: -
Current page: -
Pages added to sitemap: -
Pages scanned: - (- Kb)
Pages left: - (+ - queued for the next depth level)
Time passed: -
Time left: -
Memory usage: -


There are no values added to these fields, and I have yet to experience a browser timeout or any progress in the crawling window after 10 minutes. No sitemap is generated.

I've tried the suggestion you've made here with the saves and setting it for "run in background" with no result. In the config, I am limiting it it to 150 pages, 9000 seconds and save every 60 seconds. This was just to test and see if it was going to actually work.

I'm attempting to run this against a modified PHPnuke site. LAMP platform, PHP 4.3.x Any insight will be appreciated.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Basic Q's ref a new install.
« Reply #4 on: March 14, 2006, 04:59:34 PM »
Hello,

you can limit the maximum number of pages to index to 50, for instance to check if it works correctly.
Otherwise, please send me your generator instance URL in the Private Message.

Thank you!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

TechPad

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Basic Q's ref a new install.
« Reply #5 on: March 15, 2006, 06:54:21 PM »
Version 2.1 appears to have fixed this issue.

Thanks!

beebe

  • Registered Customer
  • Approved member
  • *
  • Posts: 1
Re: Basic Q's ref a new install.
« Reply #6 on: January 29, 2007, 11:04:34 PM »
I recently installed v2.5.1 and am having this issue.  Sometimes I get feedback in the on the sitemap generation progress, other times it will not update the screen at all.  I cannot seem to reproduce the problem at will it just happens where it was giving feedback the previous run, and now on this run it has ceased to give feedback, but still creates a sitemap correctly.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Basic Q's ref a new install.
« Reply #7 on: January 30, 2007, 10:45:11 PM »
Hello,

please try to increase max_execution_time and memory_limit settings in php configuration (php.ini).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2