XML Sitemaps Generator

Author Topic: sitemap.xml is blank, other files are normal  (Read 27654 times)

kevin

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
sitemap.xml is blank, other files are normal
« on: January 26, 2006, 12:41:36 AM »
Hi there,

Just purchased Sitemap Generator :)

I had no trouble setting up the script.  I have set the configuration and had no problems.  I have triple checked and triple checked again to make sure all the paths are correct.  They are.  So are the folder/file chmod attributes.

When I go to Crawling and RUN the script, I get the following message:

Code: [external links are visible to admins only]
...
Pages added to sitemap: 4
Pages scanned: 4 (19.5 Kb)
Pages left: 0 (+ 0 queued for the next depth level)
Time passed: 0:00
Time left: 0:00
Memory usage: 348.5 Kb
Completed
Total pages indexed: 4
Calculating changelog...
Creating HTML sitemap...

Yes it's a very small site :)

Anyway, I go into my sitemap.html file.  Everything normal, there are the 4 links

Go into my urllist.txt, everything is normal.  There are 4 links.

Go into my sitemap.xml file.  BLANK!  No Links!

-Also... if I delete my sitemap.xml file completely, it is recreated each time I run the crawl, but it is still blank no matter what.

Help!

PS:  Admin I am PM'ing you my link details so you can take a look.

Thanks,
-Kevin

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: sitemap.xml is blank, other files are normal
« Reply #1 on: January 26, 2006, 01:15:46 AM »
Hello Kevin,

you have configured the xml sitemap filename to your generator data/ folder, while it should be stored in the root of your website (this is required by google sitemap protocol).

I've corrected the settings for your Generator instance, please check it - you should create sitemap.xml file as specified and set write permissions for it.

Let me know if that helps :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

kevin

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: sitemap.xml is blank, other files are normal
« Reply #2 on: January 26, 2006, 01:25:25 AM »
Oh, was that in the instructions?   :)

Anyway it worked great now!

Thanks so much


For anyone wondering I received a fix for my problem with this script within 30 minutes!  Great support, good job :)


Thanks,
-Kevin

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2