XML Sitemaps Generator

Author Topic: segmentation fault  (Read 17401 times)

balearweb

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
segmentation fault
« on: February 05, 2008, 05:20:43 PM »
I am trying to create a sitemap for our four websites: [external links are visible to admins only] [external links are visible to admins only]  etc. Everything is working fine for the three smallest sites, but when I try to generate the map for the biggest site the script just stops almost before the end, reporting: segmentation fault (using ssh console)

The stats show:
Processing time: 28531.00s
Pages indexed: 46731
Sitemap files: 1
Pages size: 622.59Mb

If I resume the process, it concludes OK. But this has happened twice now and I think there must be a reason. I have my sitema1.xml, sitemap2.xml and sitemap2.xml in the root directory with the 666 permissions. Do I need to ad also ror1.xml, ror2.xml and ror3.xml?

Thank you for your help.

Elena



XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: segmentation fault
« Reply #1 on: February 05, 2008, 10:13:41 PM »
Hello,

please try to disable Changelog and HTML sitemap options and re-generate sitemap.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

balearweb

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: segmentation fault
« Reply #2 on: February 06, 2008, 07:38:51 AM »
I'm running the script at the moment. Lets see if it happens again or not. But I wasn't using "Create HTML Sitemap" before and I don't think the "Change log" is the origin of the problem because the segmentation fault occurred almost at the end, but still while crawling the site (there were four or five hundred pages pending). Nevertheless, thank you very much for your suggestion. I will let you know the results when I complete the current crawl.

Kind regards,

Elena

balearweb

  • Registered Customer
  • Approved member
  • *
  • Posts: 5
Re: segmentation fault
« Reply #3 on: February 20, 2008, 04:00:34 PM »
I haven't been able to avoid the Segmentation fault. But it wasn't a big problem because the day after, when the crawling began again, it would just resume the previous work and complete it.

But know I'm getting another error:

<h4>Completed</h4>Total pages indexed: 76366<br>Calculating changelog...
Warning: Invalid argument supplied for foreach() in /xxxxxxx/ge                    nerator/pages/class.templates.inc.php(2) : eval()'d code on line 75
Segmentation fault

It works fine on the smaller sites, but not wit this big one. Any suggestion?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: segmentation fault
« Reply #4 on: February 20, 2008, 09:14:22 PM »
Please try to disable "Changelog calculation" option since it's somewhat resource consuming.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2