XML Sitemaps Generator

Author Topic: mod_rewrite issue  (Read 15785 times)

Speedy B

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
mod_rewrite issue
« on: May 21, 2008, 02:16:51 PM »
Hello,
After many attempts to run this script and it failing.......I went on a mission.  I was getting the good ol' 500 error after executing the script and it running for 60 seconds and giving me the above error.  The problem was the .htaccess on my site!  I renamed the file to oldhtaccess and the script ran perfect.  The only issue that I saw was the mod_rewrite.  I have it set to always use
Code: [external links are visible to admins only]
www.my_domain.com
instead of
Code: [external links are visible to admins only]
my_domain.comfor my domain name.  This is because the google bot has indexed my site as
Code: [external links are visible to admins only]
www.my_domain.com
As I said, I renamed the file, and the script ran prefect. 
Now.....how do correct the mod_rewrite issue?  Or does it really even matter? 
BTW...now I got to fix all my broking links. (gezzzz)  ;D

This is the code in the htaccess file, of course I edited and removed my domain.

Code: [external links are visible to admins only]
#zoom zoom zoom
AddHandler fcgid-script .php
FCGIWrapper /usr/local/cpanel/cgi-sys/fcgiwrapper .php

#Go away...php.ini is for the server only
<Files php.ini>
order allow,deny
deny from all
</Files>

#You cannot see me
Options -Indexes

#Parse my silly scripts within html
AddHandler application/x-httpd-php .htm
AddHandler application/x-httpd-php .html

#Let the games begin...Always use the www, damn google bot
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^my_domain.com [nc]
rewriterule ^(.*)$ http://www.my_domain.com/$1 [r=301,nc]

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: mod_rewrite issue
« Reply #1 on: May 21, 2008, 09:18:02 PM »
Hello,

please try to create another .htaccess file in generator folder with one line:
RewriteEngine off
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

andywozhere

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: mod_rewrite issue
« Reply #2 on: March 31, 2010, 01:52:26 PM »
Quote
please try to create another .htaccess file in generator folder with one line:
RewriteEngine off

Thank you Oleg. That worked like a treat for me.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2