XML Sitemaps Generator

Author Topic: I found the solution for Crawl stop after 300 sec (5 minutes) !!!  (Read 21166 times)

ibanez.laurent

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Hello,

If you are on windows server and crawl stop after 300 sec (5 minutes) or X sec is because IIS time out cgi after X sec
When you crawl, the process "php-cgi.exe" (or php.exe) run, and it's concidered by IIS like a CGI script.

So you must edit metabase.xml (directory: WINDOWS\system32\inetsrv).
Step 1 : Enable "Allow Edit Metabase while IIS 6 is running" in IIS setting
Step 2: Edit metabase.xml in WINDOWS\system32\inetsrv\ directory with blocnote
Go to line CGITimeout and change value (default value is 300) i change to 9000
Then save.
Step 3: Disable ""Allow Edit Metabase while IIS 6 is running" in IIS setting"
Step 4: run php sitemap generator

It work !!!! (for 9000 sec in this example)

enjoy !!!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10622
Re: I found the solution for Crawl stop after 300 sec (5 minutes) !!!
« Reply #1 on: June 11, 2008, 09:03:06 PM »
Thank you for details description, helpful for IIS users.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jlabaw

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: I found the solution for Crawl stop after 300 sec (5 minutes) !!!
« Reply #2 on: January 20, 2009, 06:38:52 PM »
Great Post!

I just wanted to clarify the steps (mine were a little different which may just be due to different set ups).

Background:
I'm using Godaddy's Virtual Hosting running Windows Server 2003. If you haven't already downloaded Metabase Explorer tool from the IIS 6.0 Resource Kit. You can download the IIS 6.0 Resource Kit tools here : [external links are visible to admins only]

1) Open IIS Manager.
2) Right click ____ (local computer) and select properties.
3) Select "Enable Direct Metabase Edit"
4) From the start menu select IIS Resources then the Metabase Explorer.
5) expand ____ (local) tab.
6) Select W3SVC
7) Change the CGITimeout value by double clicking it.
8) Finally go back to IIS Manager and uncheck the "Enable Direct Metabase Edit" check box.

And that's it. I hope that helps.

Good luck

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2