XML Sitemaps Generator

Author Topic: Memory Issues Since 3.0  (Read 15142 times)

eric3

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Memory Issues Since 3.0
« on: June 10, 2009, 03:14:41 PM »
Since I updated to 3.0 I am now getting a memory issue. Nothing on my server has changed. I have the directory .htaccess setup with:

php_value max_execution_time 500000
php_value memory_limit 128M

and when I check it with PHP info I see:

max_execution_time   500000   300
memory_limit   128M   32M
safe_mode   Off   On

but when I run the script (via cron job) I get:

PHP Warning:  set_time_limit(): Cannot set time limit in safe mode in (*****siteroot*****)/sitemapmaker/pages/class.grab.inc.php(2) : eval()'d code on line 8 Allowed memory size of 33554432 bytes exhausted (tried to allocate 12 bytes)

Ideas?

UPDATE:
I think the problem comes up in that since I am now running it via cron tab it defaults to the master PHP settings instead of the local. Before 3.0 I was starting by using curl and touching runcrawl.php, but now in 3.0 you can't do that so I had to switch to using php directly.
When I use the given command line for cron I get:
/bin/sh: /usr/local/bin/php: No such file or directory

So I switched to
/usr/bin/php
and that works, but it gives me the safe mode and memory error.

When I try and use CURL now I get:

This tool can be executed in command line mode only

Ideas?
« Last Edit: June 10, 2009, 03:34:52 PM by eric3 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Memory Issues Since 3.0
« Reply #1 on: June 10, 2009, 11:58:20 PM »
Hello,

please try to change memory_limit setting in php.ini file that is used when running script in ssh, so that it takes effect.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

eric3

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Memory Issues Since 3.0
« Reply #2 on: June 11, 2009, 06:08:06 PM »
My host will not allow me to make changes to the php.ini file. Anyway to remove the "command line mode only" restriction on the runcrawl.php so I can hit that will curl again?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Memory Issues Since 3.0
« Reply #3 on: June 12, 2009, 03:16:30 AM »
Hello,

yes, please try to change runcrawl.php file as described here: http://www.xml-sitemaps.com/forum/index.php/topic,2274.html
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2