XML Sitemaps Generator

Author Topic: Broken links  (Read 11008 times)

Renate Schedl

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Broken links
« on: July 18, 2009, 05:45:33 PM »
When generating my sitemap I get a report about broken links.
I do not understand this report. All broken links refer to my amazonewidget. I have included a link into my blog pointing to my amazonshop. But the visitors do ot get any 404 erors, because all links work perfectly.

Will this broken links in the report harm when sending the sitemap to google?

When the crawling is running, I can watch the progress. And it says ...deeper level on queue (or somethign like that). But only leel 1 is crawled. In the configuration it should crawl down to level 150 maximum.

Why are the other levels (on queue) not crawled.

Sorry for all the questions. Is my first experience with sitemaps.

Renate Schedl

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Broken links
« Reply #1 on: July 19, 2009, 02:44:29 AM »
O.K., the first pat of my question about the broken links has been solved. Reason : I had two amazon widges included, which caused the broken links. After I took them out of my blog, no broken link showed up anymore.
I still do not know, why those widgets caused broken links, because when you click on them as a visitor, all links are working perfectly. But anyhow, by deleting the widgets I got rid of the broken links.

But the problem with only crawling the first level still remains. And I would like to find a solution for that too.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Broken links
« Reply #2 on: July 19, 2009, 07:08:11 AM »
Hello,

is the sitemap created at that point or not?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

Renate Schedl

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 13
Re: Broken links
« Reply #3 on: July 20, 2009, 01:35:47 AM »
The sitemap is created, but only 1 level deep. While the crawling process was running, the status messages where talking about many pages of deper level are in the queue. So I expected more than one level, when the report had finished.

Am I wrong with this expectation? Or are the external links, which can be seen in another report, those deeper levels held in the queue?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Broken links
« Reply #4 on: July 21, 2009, 09:59:10 AM »
Hello,

could you please PM me your generator URL and an example URL that is not included in sitemap and how it can be reached from homepage?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2