XML Sitemaps Generator

Author Topic: Can't Save the Configuration  (Read 12637 times)

drsyedwajid

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Can't Save the Configuration
« on: February 26, 2010, 11:54:16 AM »
I try to save the config for other domain and still it shows the old data...plz help

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Can't Save the Configuration
« Reply #1 on: February 27, 2010, 01:58:42 PM »
Hello,

make sure that you have 0777 permissions set for generator/data/ folder and 0666 permissions for all files inside of data/ folder.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

build

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Can't Save the Configuration
« Reply #2 on: March 04, 2010, 09:26:19 PM »
I am also having problems saving the generator.conf with the permissions set as described.

-rw-rw-rw- 1 stewart www-data 0 2010-03-04 13:06 ror.xml
-rw-rw-rw- 1 stewart www-data 0 2010-03-04 13:06 sitemap.xml
drwxrwxrwx 3 stewart www-data 4096 2010-03-04 13:16 generator/data/

On first run it will create a generator.conf and sess_* in the data folder owned by www-data, however, changes to the configuration will not be saved and sitemaps cannot be generated. If I manually edit generator.conf, those changes are reflected.

I am using v3.0 on Ubuntu Linux 9.10 (karmic) 64-bit with PHP 5.2.10 installed from the Ubuntu repositories. Are there any required php params that are required that Ubuntu might have changed in their config? I checked the obvious (safe_mode and safe_mode_gid, both are off) but I am not a PHP expert.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Can't Save the Configuration
« Reply #3 on: March 05, 2010, 08:10:17 PM »
Hello,

please try to set 0666 permissions for generator.conf file (after it's created)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

build

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Can't Save the Configuration
« Reply #4 on: March 08, 2010, 09:16:39 PM »
I did the chmod as suggested, however I am still experiencing the same issue.

-rw-rw-rw- 1 www-data www-data 1762 2010-03-04 13:16 generator.conf

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Can't Save the Configuration
« Reply #5 on: March 10, 2010, 02:57:58 PM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

payment99

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Can't Save the Configuration
« Reply #6 on: April 10, 2010, 01:52:09 AM »
I have the same problem. I've set the permissions for the config file to 666 and tried to save a new configuration, but nothing changed in the config file.

All that happens when I click the save button is that everything on the form resets to the preset configuration.

Fortunately I had changed my old files to rorOld.xml and sitemapOld.xml so was able to change them back again.

This problem started yesterday when I tried to run your 2-year-old standalone and was told that there were server problems. So I looked through my emails and couldn't find my purchase details, and as the price isn't high, I just bought a new one, deleted all the old Generator files from my site, and installed the new ones.

I've now found my purchase details in the Paypal mailbox (I was looking in the Purchase mailbox) and I bought the old one on Tue, 16 Jan 2007, so it has seen some good use!

Oh, my computer is on XP Pro Windows, and my server is on Linux as far as I remember.

Ian McAllister

payment99

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Can't Save the Configuration
« Reply #7 on: April 10, 2010, 01:51:31 PM »
I've just had a horrible thought.

There is something in the password section of configuration.

Does this mean that unless I type in whatever garbage happened to be in this field when I first tried the configuration, I won't be able to configure it again? I don't want a password.

Ian McAllister

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Can't Save the Configuration
« Reply #8 on: April 11, 2010, 06:27:26 AM »
Hello,

you can just ignore the password field and there will be no password defined, it shows 5 "stars" in there by default.

Make sure that you have 0777 permissions set for generator/data/ folder.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

payment99

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Can't Save the Configuration
« Reply #9 on: April 12, 2010, 04:23:07 AM »
Hi,

PROBLEM SOLVED so I include details for anybody else who is trying to use
the generator for add-on domains.

I've been trying to figure out what is happening.

1. I deleted generator.conf from the site, then configured and saved the file again

without a password. Then I set the permissions on the new file to 666 and

downloaded it to my computer. Then I opened default.conf and generator.conf side

by side in Notepad.

The first thing I noticed was that a password is inserted, even though I left that line

blank.

Next I noticed that the path to my files was
name="xs_smname">/usr/home/public_html/sitemap.xml</option>

That's a possible problem because that path doesn't exist.

I'm using an add-on domain, which is set so that / means
name="xs_smname">/usr/home/public_html/</option>

So I tried changing it to
/sitemap.xml
but the form just resets itself to the old setting.

Do I have to place Generator in the root domain to make it work? If so, would I be unable to use it for more than one add-on domain?

......................................................
SUCCESS
1. I opened Filezilla in the root domain instead of my addon demain, and transferred Generator. (incidentally, the case matters, so generator is not Generator)

2. I created blank ror.xml, sitemap.xml, sitemap.txt (this was a mistake) and sitemap.html files in public_html/addondomain/

3. I changed their permissions to 666 then changed the data directory permissions to 777.

4. I browsed to [external links are visible to admins only] and up came the configuration page.

5.  Starting URL: appeared as rootdomain.info, so I changed it to addondomain.info.

6. Save sitemap to: I changed to
/home/famimca1/public_html/addondomain/sitemap.xml

7. Your Sitemap URL: I changed to [external links are visible to admins only]

8. HTML Sitemap filename I changed to
/home/famimca1/public_html/addondomain/sitemap.html

9. I crawled the site and everything worked, except for the sitemap.html which gave me a server error message.

10. That was using Filezilla for my root domain, and the new files showed nicely. So I closed that domain, and opened my addon domain and nothing showed. However when I closed Filezilla, and re-opened it, the new files showed in my addon domain.
11. The sitemap.html was there OK, but it still generated a server error. So I downloaded it to my computer, deleted the file onsite, and uploaded it again. It worked. So I don't know what was the glitch.

12. The config page still insists on putting in a password, so I suppose I had better use one instead of the default one.

CONCLUSION.

All the problems except the password one, were caused by my domain being an addon domain. Many people have addon domains, so it might be good to include something about them in the instructions.

Ian McAllister

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Can't Save the Configuration
« Reply #10 on: April 12, 2010, 07:36:01 AM »
Thank you for posting a detailed follow-up!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2