XML Sitemaps Generator

Author Topic: generator putting in a period (.) after domain name so error on opening sitemap  (Read 25103 times)

clarefurler

  • Jr. Member
  • **
  • Posts: 18
Hi there,

I posted a question before about not being able to get the generator to index more than just the root page. I figured out that when I opened the generator for the first time, just with this particular website, in some of the configuration fields, it was putting a fullstop or period (.) after the domain name. I removed this and the generator indexed all the pages. While I can open the ror.xml, sitemap.html and urlist.txt files, I cannot open the sitemap.xml file. It is saying that there is an error and I notice that it too has put a period after the domain name. It is very strange. I can't see how to get rid of this or why it is there in the first place.

Here is a link to the generator in question:
[external links are visible to admins only]

Thanks in advance!
Clare

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10622
Hello,

looks like there was a dot (.) in "Your Sitemap URL:" setting as well, it looks ok now though.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

clarefurler

  • Jr. Member
  • **
  • Posts: 18
Hi, thanks for the reply!

I'm afraid, it's still not working. The sitemap url looks okay and when you roll over it, it still looks ok, but when you click on it, this is where it goes to:

[external links are visible to admins only]

I am seeing this message:

Error loading stylesheet: A network error occurred loading an XSLT stylesheet:

[external links are visible to admins only]

As you can see, there's a dot after the url in there too. It's bizarre!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10622
Mm.. yes, strange. Please try to modify pages/mods/sitemap_xml_tpl.xml file:
find:
Code: [Select]
<?xml-stylesheet type="text/xsl" href="%GEN_URL%pages/mods/sitemap.xsl"?>replace with:
Code: [Select]
<?xml-stylesheet type="text/xsl" href="http://www.yourdomain.com/generator/pages/mods/sitemap.xsl"?>and recreate sitemap.
« Last Edit: May 24, 2012, 05:35:27 AM by XML-Sitemaps Support »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

clarefurler

  • Jr. Member
  • **
  • Posts: 18
Oh excellent!! That has worked. It is working perfectly now.

Thank you VERY much for all your help! :)

Clare

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2