XML Sitemaps Generator

Author Topic: Invalid argument error when trying to generate sitemap  (Read 9460 times)

clarefurler

  • Jr. Member
  • **
  • Posts: 18
Invalid argument error when trying to generate sitemap
« on: November 19, 2010, 04:06:22 PM »
Hi there,

I was wondering if you could help me. I have a website that was done by somebody else in Wordpress and I am trying to put the XML sitemap onto it. I have all the files loaded as usual where I think they should be loaded (like I said, someone else did the website and it's not my usual way of doing them). Everything looks to be in order but when I try to crawl for indexing to create the sitemap etc, it won't index any pages and this error comes up:

Warning: Invalid argument supplied for foreach() in /var/www/vhosts/dublindental.ie/httpdocs/generator/pages/class.html-creator.inc.php(2) : eval()'d code on line 89

This is the website:
[external links are visible to admins only]

Thanks a lot if you can help me!!

Clare

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Invalid argument error when trying to generate sitemap
« Reply #1 on: November 19, 2010, 04:13:48 PM »
Hello,

looks like you have all pages blocked with your robots.txt file, you can check that using our search engine bot simulator tool: http://www.xml-sitemaps.com/se-bot-simulator.html?op=se-bot-simulator&go=1&pageurl=http%3A%2F%2Fwww.dublindental.ie&se=googlebot&submit=Start
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

clarefurler

  • Jr. Member
  • **
  • Posts: 18
Re: Invalid argument error when trying to generate sitemap
« Reply #2 on: November 19, 2010, 04:46:08 PM »
Thanks a lot for that! I will have to go to the original people and see if it's okay with them that I delete this.

Thanks again!!

Clare  :D

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2