XML Sitemaps Generator

Author Topic: Wrong file permissions...  (Read 7820 times)

florian1

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Wrong file permissions...
« on: August 29, 2011, 08:06:51 PM »
After running the crawler I get

Code: [external links are visible to admins only]
Error writing to these files:
/srv/www/vhosts/domain.de/httpdocs/ror.xml
/srv/www/vhosts/domain.de/httpdocs/sitemap_de.xml.gz
/srv/www/vhosts/domain.de/httpdocs/sitemap_images.xml.gz
Please correct files permissions and resume sitemap creation.

While ror.xml permissions are set to
Code: [external links are visible to admins only]
-rw-rw-rw-  1 user psacln  3070172 29. Aug 12:23 ror.xml

So the questions are

1) Do I have to create manually a "sitemap_de.xml.gz" and "sitemap_images.xml.gz" file?

2.) Whats worng with the existing for.xml file?

3)If my site is large, do I have to also create sitemap_de1.xml, sitemap_de2.xml, sitemap_de3.xml, and so on files?

Kind regards
Fl÷zen

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Wrong file permissions...
« Reply #1 on: August 30, 2011, 09:58:51 PM »
Hello,

1. yes, you should create them and set 0666 permissions

2. please verify that the path is exactly correct too.

3. yes, those files will need to be manually created (since php script will not have permissions to create them by default)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

florian1

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Wrong file permissions...
« Reply #2 on: August 31, 2011, 03:25:19 AM »
Quote
2. please verify that the path is exactly correct too.

As you can see, the ror.xml file is 3070172 byte large, thus the path must be correct. How else should the generator be able to write these 3070172 bytes?

Thanks,
Florian

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Wrong file permissions...
« Reply #3 on: August 31, 2011, 08:49:09 AM »
Looks like it's displayed just because main sitemap was not written. Please try to correct the issue with xml sitemap and see if that works.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2