Getting error
« on: October 12, 2011, 04:03:17 PM »
I am trying to set up another website's property listings sitemap to work like my other account where only one page is scanned that has a few hundred links to property listings for different zipcodes.  We purchased your software separately for tis new website and I set it up the same way my other one is set up.... but I am getting this error when I try to crawl the site.

Invalid argument supplied for foreach() in /home/staveley/public_html/generator/pages/ on line 102 
Re: Getting error
« Reply #1 on: October 13, 2011, 01:39:38 PM »

does it create sitemap though? What is the number of URLs indexed?
(that message is a warning that usually appear when no pages were included in sitemap)
Re: Getting error
« Reply #2 on: October 13, 2011, 02:49:59 PM »
No, it's actually not creating the sitemap.  I have it set up the same way as the other site though.

I want it to scan this page:
 [ External links are visible to forum administrators only ]

....and have it follow each zip code link to scan all the individual properties in each zip code.  I dont want it to scan anything else.   I set it up like this:

Include only:    mls-
parse only:      search-zipcodes/idx/zip/

this set up works on the other site.  You had helped me set that one up though so I am not sure if I am missing something else.   

I sent you a pm with login details in case you need it.
« Last Edit: October 13, 2011, 03:04:22 PM by bill27 »
Re: Getting error
« Reply #3 on: October 13, 2011, 07:34:05 PM »

all your pages are blocked with your robots.txt:
User-agent: *
Disallow: /
Re: Getting error
« Reply #4 on: October 13, 2011, 07:43:13 PM »
Hello Oleg,
WOrdpress was set to block search engines since the site is still in development.  I unblocked it, but it is still not working...same error.
Re: Getting error
« Reply #5 on: October 13, 2011, 09:04:55 PM »
You had no space in "search-zipcodes/idx/zip/" setting, I've changed it to:
Code: [Select]
search-zipcodes idx/zip/
Re: Getting error
« Reply #6 on: October 14, 2011, 02:23:23 AM »
Ahhh... I see.  I knew I was close!  I am not sure why you have to have a space...

Thank you so much for your help!!!