XML Sitemaps Generator

Author Topic: UTF-8 encoding  (Read 9109 times)

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
UTF-8 encoding
« on: January 13, 2012, 11:58:40 AM »
Hi,

my website is UTF-8 encoded. So i've chosen UTF-8 in the presets.

Problem is, that the generated HTML sitemap file doesn't have an UTF-8 meta tag included. So digits like & aren't displayed the right way.
Please take a look at: [external links are visible to admins only]

How can i fix that?

Thanks & regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: UTF-8 encoding
« Reply #1 on: January 13, 2012, 03:29:52 PM »
Hello,

you need to modify generator/pages/mods/sitemap_tpl.html file by adding charset meta tag if you want to change html sitemap encoding.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
Re: UTF-8 encoding
« Reply #2 on: January 17, 2012, 11:34:38 PM »
Thanks, it works great after modification.

Is there also a way to tell the ror.xml and the other xml's that they have to use utf-8?
Because i get things like "»" or  "«" when i call the files.

Thanks & regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: UTF-8 encoding
« Reply #3 on: January 18, 2012, 07:22:53 PM »
Hello,

can you provide an example with these characters?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
Re: UTF-8 encoding
« Reply #4 on: January 18, 2012, 11:04:36 PM »
Yes, please take a look:

[external links are visible to admins only]

and search for:
& » «

Thanks & regards
« Last Edit: January 18, 2012, 11:06:52 PM by 989 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: UTF-8 encoding
« Reply #5 on: January 20, 2012, 01:39:36 PM »
Hello,

please try to enable "UTF" setting in generator configuration.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
Re: UTF-8 encoding
« Reply #6 on: January 20, 2012, 01:56:43 PM »
Hi,

UTF-8 is already enabled in the configuration (Advanced Settings).
What else can i do?

Thanks & regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: UTF-8 encoding
« Reply #7 on: January 23, 2012, 11:57:35 AM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2