XML Sitemaps Generator

Author Topic: XML Sitemap & Bad Code ?  (Read 10469 times)

prodvideo

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
XML Sitemap & Bad Code ?
« on: May 13, 2014, 09:16:39 PM »

I've been creating sitemaps with XML Sitemap Generator, and have been downloading them to edit on my pc.  The sitemaps work fine when viewing in a browser, but when I download and open in Dreamweaver, the urls don't work when I cut and paste them in the Firefox URL bar.  I notice the codes are different.  For example, an "&" is produced like this..."&".  Extra characters are inserted, producing the error.

I was wondering if this is normal, because as I said, the map works fine when viewing online.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10622
Re: XML Sitemap & Bad Code ?
« Reply #1 on: May 14, 2014, 04:29:49 AM »
Hello,

all links must be urlencoded in xml sitemap according with protocol:
http://www.sitemaps.org/protocol.html
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

prodvideo

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: XML Sitemap & Bad Code ?
« Reply #2 on: May 14, 2014, 01:13:43 PM »
Thank you very much for the reply and for the link.  I understand now this is the way it's supposed to be coded, and that symbols like "&", must be scripted as "&" in sitemap to comply with the sitemap protocol, so the code is all good.  I apologize for the misunderstanding, and thus far I'm loving your product!

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2