XML Sitemaps Generator

Author Topic: It works for a while and then nothing happens  (Read 14730 times)

info2839

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
It works for a while and then nothing happens
« on: August 16, 2015, 08:03:14 PM »
I just purchased de generator and tried a couple of times to create a sitemap.
It runs for 20 minutes and then nothing happens, i run again and then 5 minutes and stops again.
No sitemap is created (file stays empty)
I also tried resume last state but not working.

where can i find a solution?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #1 on: August 17, 2015, 06:21:08 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

info2839

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #2 on: August 17, 2015, 07:43:14 PM »
My webshost uses cpanel, in there i have 1024 MB available, while generate i can see it uses maximum 200Mb so that should not be an issue.
I also deleted 180.000 articles from my database to make everything a bit faster but still not working.
Estimated links at the website is 100.000

info2839

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #3 on: August 18, 2015, 07:47:04 AM »
I've answer from my webhost, the memorysize = 128M and execute time = 30
they do not change this for me so now i cannot use this script?

I used other free scripts and they have some issues, thats why i purchase one.
when i read this forum many people have this problem, and the answer is always increase memory_limit.


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #4 on: August 18, 2015, 08:09:29 AM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

info2839

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #5 on: August 23, 2015, 07:35:43 AM »
There is still no solution, i don't have ssh access permission so i can not use this script? Why you do not warn people before they purchase? according to this forum i am not the only one running problems.
Is there any option for a refund? of course i rather have a full sitemap but i think this will never work.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #6 on: August 23, 2015, 07:59:31 AM »
Hello,

replied to your email.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ncoppola

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #7 on: September 10, 2015, 08:20:49 PM »
Hello,

Is there a solution for this? Can you provide setting examples?

My process runs for a while and then stops.  I need to refresh the page to pick up where it left off, or at least it appears that way.  I still don't have the actual sitemap file populated although the message says it is building it.

Thanks,

- Nick

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #8 on: September 11, 2015, 05:37:19 AM »
Hello, 

in this case I would recommend to run generator in command line if you have ssh access to your server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ncoppola

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #9 on: September 11, 2015, 07:46:05 PM »
How do we run it from the command line? CMD?   Do you have any more details?


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #10 on: September 12, 2015, 11:35:01 AM »
The command line is displayed on the Crawling page of sitemap generator.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ncoppola

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #11 on: September 16, 2015, 06:20:49 PM »
Hi Oleg,

I was able to get the command line running in Windows.  It works better.  However, I'm not seeing the sitemap getting built in the xml files we added to the root.  I gave "Everyone" full rights to those files.  When does the sitemap actually get put into the xml files?

Thank you.

- Nick

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #12 on: September 17, 2015, 06:48:09 AM »
Hello,

you need to allow write access for IUSR_* usergroup (allowing "Everyone" group is not sufficient)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ncoppola

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: It works for a while and then nothing happens
« Reply #13 on: September 17, 2015, 12:25:17 PM »
IIS_IUSR was given full rights to the xml docs.  I still don't see the file being saved.  Does it wait until the process is complete?  Is there a way for me to see errors? It is days now trying to get this to work.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: It works for a while and then nothing happens
« Reply #14 on: September 18, 2015, 05:32:29 AM »
Yes - sitemaps are created only after the crawling is completed.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2