XML Sitemaps Generator

Author Topic: Sitemap does not work / takes extremely long time  (Read 2441 times)

harte9241

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Sitemap does not work / takes extremely long time
« on: June 10, 2016, 07:07:14 AM »
Hi,

I have a sitemap + images on [external links are visible to admins only]. It works fine when I ask a sitemap for 1000 pages, which I did to test. 1000 pages and 41000 images. However, when I tried the whole site (63500 pages and 125000 images), it did do nothing, even after 1,5 weeks (!!!) of running, even though I could not see if it actually did something.

As the 1000 page sitemap worked fine, it seems that the installation is OK. What to do ?
« Last Edit: June 10, 2016, 08:01:26 AM by harte9241 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Sitemap does not work / takes extremely long time
« Reply #1 on: June 10, 2016, 09:18:25 AM »
Hello,

The crawling time itself depends on the website page generation time mainly, since it crawls the site similar to search engine bots.
For instance, if it it takes 1 second to retrieve every page, then 1000 pages will be crawled in about 16 minutes.

If  1,5 weeks have passed then sitemap generator was stopped after some time and you need to run it again, resuming the process.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

harte9241

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Sitemap does not work / takes extremely long time
« Reply #2 on: June 15, 2016, 06:08:58 PM »
I tried several times to restart, but even 2500 pages does not work within a day. Why is that not working ? I need a good sitemap for my site, and this is getting useless...

[external links are visible to admins only]

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Sitemap does not work / takes extremely long time
« Reply #3 on: June 16, 2016, 05:58:49 PM »
Looks like sitemap has been created:
Created on:
30 May 2016, 06:26
Processing time:
0:04:46s
Pages indexed:
1000
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Sitemap does not work / takes extremely long time
« Reply #4 on: June 16, 2016, 05:59:37 PM »
Also, you need to set "Save the script state, every X seconds:" setting to "30" (default) or "60", otherwise script state is not saved and you never resume it as a result.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

harte9241

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Sitemap does not work / takes extremely long time
« Reply #5 on: June 17, 2016, 05:18:50 AM »
The 1000 page sitemap works, but anything larger does not. I'll try the othe roption.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2