ccw

*
  • *
  • 2
Cannot generate Sitemap after adding URLs for 100+ languages
« on: December 22, 2020, 06:09:55 AM »
Hi,

In the past, I use Sitmap generator to generate sitemap for our website without any problems. I check the log and find it takes about 5 hours to process all 12942 pages in our site.

Now we have added 100+ language support to our website. The languages are put under the subfolders of the main site, like this, [ External links are visible to forum administrators only ]

So I add all the language URLs to "Custom alternative language pages" in the "Advanced" option.

After that, I have never been able to complete the sitemap generation any more.

When I start the creation(run in background), initially I can see the progress update. However, after several hours, when I check back, I will either see the creation sitemap page as if no creation process is running, or I cannot see the creation button any more.

When I click "View sitemap", I will always see the information of the previous created sitemap, not the current one.

How to solve the problem?
Re: Cannot generate Sitemap after adding URLs for 100+ languages
« Reply #1 on: December 23, 2020, 07:50:26 AM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 

ccw

*
  • *
  • 2
Re: Cannot generate Sitemap after adding URLs for 100+ languages
« Reply #2 on: December 23, 2020, 10:28:31 PM »
Thank you. I have solved the issue by adding the lanauge URLs to include but no follow list.