PHP 8 compatibility?
« on: January 26, 2021, 05:03:06 AM »
Any news on when a new version will be out that is compatible with php8?  I just upgraded from 7.4 to 8 and the manual sitemap creation from the interface errors out.  I haven't tried running it with cron, but would assume the same.

Update - tried it with the cron.  Error output provided below.  There have always been a ton of undefined variable warning, but this shows an incompatibility with php8.

Code: [Select]
[26-Jan-2021 05:15:01 UTC] PHP Warning:  Undefined variable $ZWvSXGV0H2v in /home/example/public_html/xmlsitemap/runcrawl.php on line 102
[26-Jan-2021 05:15:01 UTC] PHP Fatal error:  Uncaught TypeError: in_array(): Argument #2 ($haystack) must be of type array, null given in /home/example/public_html/xmlsitemap/runcrawl.php:102
Stack trace:
#0 /home/example/public_html/xmlsitemap/runcrawl.php(102): in_array('ddbg', NULL)
#1 {main}
  thrown in /home/example/public_html/xmlsitemap/runcrawl.php on line 102


« Last Edit: January 26, 2021, 05:53:47 AM by morrow »
Re: PHP 8 compatibility?
« Reply #1 on: January 30, 2021, 09:25:05 AM »
What is the error you get when running via web interface?
Re: PHP 8 compatibility?
« Reply #2 on: January 30, 2021, 05:07:29 PM »
What is the error you get when running via web interface?

Lots of warnings with undefined arrays and variables plus the following :

Code: [Select]
[30-Jan-2021 17:02:16 UTC] PHP Fatal error:  Uncaught Error: Undefined constant "tru" in /home/example/public_html/xmlsitemap/pages/class.grab.inc.php:102
Stack trace:
#0 /home/example/public_html/xmlsitemap/pages/class.grab.inc.php(692): SiteCrawler->v67O66mm3(0, true)
#1 /home/example/public_html/xmlsitemap/pages/page-crawlproc.inc.php(212): SiteCrawler->o3C1linuEo77eoG1Jf(Array)
#2 /home/example/public_html/xmlsitemap/index.php(102): include('/home/example/pu...')
#3 {main}
  thrown in /home/example/public_html/xmlsitemap/pages/class.grab.inc.php on line 102
Re: PHP 8 compatibility?
« Reply #3 on: February 03, 2021, 04:36:48 PM »
We will look into it, thank you for reporting.
Re: PHP 8 compatibility?
« Reply #4 on: February 24, 2021, 03:07:52 PM »
Thanks for the 8.1 update - working perfectly fine again!
Re: PHP 8 compatibility?
« Reply #5 on: February 24, 2021, 04:52:01 PM »
Great, I'm glad it works now! :)