XML Sitemaps Generator

Author Topic: Installing on 2 web server + load balancer environment  (Read 22877 times)

ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Installing on 2 web server + load balancer environment
« on: July 23, 2007, 03:27:13 PM »
Hi,

My environment grew up and I have 2 web-servers (www1,www2..) and LB server.
Where should I install the generator ?

Thanks,

Ofer.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10764
Re: Installing on 2 web server + load balancer environment
« Reply #1 on: July 23, 2007, 09:15:23 PM »
Hello,

you can install Sitemap Generator on one of the servers and setup automatic sync for resulting sitemap files to have them on both servers.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: Installing on 2 web server + load balancer environment
« Reply #2 on: July 24, 2007, 03:44:37 PM »
Okay,
Will try, I was sure that the fact that they are now www1 and www2 will generate www1.domain.com pages.


ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: Installing on 2 web server + load balancer environment
« Reply #3 on: July 26, 2007, 09:56:28 AM »
it seems that now the sitemap generator only recognizes www1.domain.com as the base-URL.
when i try to set the starting URL to [external links are visible to admins only] it results with an error saying:"there was an error while retrieving the URL specified: [external links are visible to admins only], error opening socket to..."

it seems that the sitemap gen. doesn't recognizes [external links are visible to admins only] only www1.domain.com (probably since it's installed on www1). is there a way to make it work?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10764
Re: Installing on 2 web server + load balancer environment
« Reply #4 on: July 26, 2007, 12:19:33 PM »
Hello,

it seems like DNS configuration issue on your host, you can try to specify starting URL as http://www.domain.com/ and then manually define IP in config.inc.php file:
Code: [Select]
    'xs_ipconnection' => 'xx.xx.xx.xx',
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: Installing on 2 web server + load balancer environment
« Reply #5 on: July 26, 2007, 04:55:46 PM »
Okay, that helped, it started working but now it's stops after 2,000+ pages.
BTW I downloaded from the original link and got v2.3
I assumed it's the newest version but now I noticed you were talking about recent release of v2.5.1
How do I get it ?


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10764
Re: Installing on 2 web server + load balancer environment
« Reply #6 on: July 26, 2007, 09:12:05 PM »
Hello,

the latest version is 2.5.3, make sure that you uploaded all new files to your server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: Installing on 2 web server + load balancer environment
« Reply #7 on: July 28, 2007, 08:54:09 AM »
Oleg,
What I'm saying is that I downloaded it from the original link and still what I get is v2.3
Can you push the current version to my email ?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10764
Re: Installing on 2 web server + load balancer environment
« Reply #8 on: July 30, 2007, 06:14:31 AM »
Ok, sent it to you directly via email.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ofer

  • Registered Customer
  • Approved member
  • *
  • Posts: 6
Re: Installing on 2 web server + load balancer environment
« Reply #9 on: July 31, 2007, 02:06:14 PM »
Hi,

I didn't see it in my inbox. I have a screening system. Can you post the email you are using so I can confirm it ?
And please make sure you send it to ofer[at]infomedia-2000.com

Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10764
Re: Installing on 2 web server + load balancer environment
« Reply #10 on: July 31, 2007, 09:09:37 PM »
I've sent it to you via Private message.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.13 | SMF © 2014, Simple Machines
XHTML RSS WAP2