Google error
« on: October 22, 2007, 02:34:20 PM »
I created my sitemap and submitted to Google, but it returns an error.

XML Parsing Error: junk after document element
Location: http://whitebirchstudios.com/sitemap.xml
Line Number 8, Column 1:

What to do?
Re: Google error
« Reply #1 on: October 22, 2007, 06:45:52 PM »
I must echo this, haven't even got as far as Google submission. I just view the sitemap in Firefox and it says:

XML Parsing Error: junk after document element
Location: http://xxxxxxxxxx/sitemap.xml
Line Number 8, Column 1:<url>
^

First few lines of the xml source code:

<url>
  <loc>http://xxxxxxxxxxxxxx/</loc>
  <priority>0.50</priority>
  <lastmod>2007-10-22T18:03:35+00:00</lastmod>
  <changefreq>weekly</changefreq>
</url>
<url>
  <loc>http://xxxxxxxxxxx/forumdisplay.php?f=2</loc>
  <priority>0.40</priority>
  <lastmod>2007-10-22T18:03:35+00:00</lastmod>
  <changefreq>weekly</changefreq>
</url>
Re: Google error
« Reply #2 on: October 23, 2007, 12:22:50 AM »
any assistance here?
Re: Google error
« Reply #3 on: October 23, 2007, 02:00:08 AM »
Hello,

please re-download sitemap generator package using the same link and update all generator/pages/* files on your server. There were missing xml template files in previously packed version.
My apologies for inconvenience.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Google error
« Reply #4 on: October 23, 2007, 04:24:07 AM »
Worked, thanks!
Re: Google error
« Reply #5 on: January 01, 2008, 11:14:18 PM »
I created my sitemap and submitted to Google, but it returns an error.

XML Parsing Error: junk after document element
Location: http://whitebirchstudios.com/sitemap.xml
Line Number 8, Column 1:

What to do?
Your sitemap location is http://www.whitebirchstudios.com/sitemap.xml - you added the "www." in config but maybe you informed Google of the http://whitebirchstudios.com/sitemap.xml location - that can cause errors for mismatched URLs - just add your site to Google again (and verify) under http://www.whitebirchstudios.com
You're causing a redirect at the moment.

It may well not be the answer but that will help in some way I'm sure  :D