XML Sitemaps Generator

Author Topic: Stops Working  (Read 65093 times)

elite

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Stops Working
« on: January 15, 2006, 10:12:05 PM »
When the generator is finished the screen just stays like this one below.  The sitemap doesn't get changed nor the changelog.

Links depth: 10
Current page: articleprint/225/33/Leases-Leasing/Business/3/
Pages added to sitemap: 10698
Pages scanned: 11311 (149,174.3 Kb)
Pages left: 0 (+ 0 queued for the next depth level)
Time passed: 8:15
Time left: 0:00
Memory usage: 7,406.4 Kb
Completed
Total pages indexed: 10698
Calculating changelog...

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #1 on: January 16, 2006, 11:28:23 AM »
Hello elite ,

perhaps a memory exceeded error occurs while calculating changes. Please turn off the "Calculate changelog" option on configuration page.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

elite

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Stops Working
« Reply #2 on: January 18, 2006, 12:44:18 AM »
I turned it off and it still stays locked in the screen with no change to the sitemap.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #3 on: January 18, 2006, 01:43:12 AM »
Hello,

do you work with the latest version? Please try v2.0 of generator (it has just been released).
Make sure you have disabled "calculate changelog"  and "create html sitemap" disabled (to get less memory usage).

If the problem still exists, please send me in Private Message the URL to your Generator instance.

Thank you!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #4 on: January 18, 2006, 04:24:21 AM »
I have the same problem with 2.0 which I downloaded just now. It was working great with 1.2.2.

 I have this in a Windows IIS6 env with php 4.3.4.

After running 2.0 manually I get the page described above and I am unable to go to any other pages on the screen. Looking at Windows  taskmanager it shows the php.exe session staying pegged at about 50%.

If I kill the php.exe session and try to start another session of the xml generator the screen is blank.

If I go into the /data subdir and delete everything there, I can then run xml generator get to the config page and then attempt to run another crawl, but then I get the error at the top and the problem starts all over again.

Whatever is in the /data directory keeps xml genertor from starting up....

I restored my v 1.2.2 because it is working great. Hopefully you can get this sorted out because the html sitemap is a great idea.

Andy

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #5 on: January 18, 2006, 10:58:46 AM »
Hello Andy,

did you tried to execute crawler with "html sitemap" option disabled (as I have asked above)?

Thanks!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #6 on: January 18, 2006, 12:34:30 PM »
Yes, disabled optional html and txt sitemaps and no changelog generation.

Do you have an optional variable for debug mode where it could dump everything to a log? If not you might want to consider it.

Whats wierd is that even after I kill the php background process and try rerunning xml generator, it will not come up until I remove the contents of the /data directory. Does your program have some kind of resume mode when it first starts up where it checks the /data directory for certain information ???

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #7 on: January 18, 2006, 02:22:17 PM »
Hi,

sure, the "Resume generation" is one of the generator's features. You can set "Save the script state, every X seconds" to 0 at Configuration page to disable it (it's default value though).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #8 on: January 19, 2006, 04:27:00 PM »
Tried various combinations of things, enabling and disabling feature and trying different values for every option in the config page with no luck. Same sympton as at the top of this thread.   :(

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #9 on: January 19, 2006, 05:59:06 PM »
Could you please let me know the URL of your generator instance (in Private Message)?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

elite

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Stops Working
« Reply #10 on: January 21, 2006, 03:08:51 AM »
I have the upgraded version.  I've tried all the options same as apaluch.  Any luck with apaluchs site admin?

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #11 on: January 21, 2006, 05:01:56 AM »
[external links are visible to admins only]
I have the upgraded version.  I've tried all the options same as apaluch.  Any luck with apaluchs site admin?

Are you running this under Windows or Linux? Just curious ...

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Stops Working
« Reply #12 on: January 21, 2006, 03:12:21 PM »
Hi elite,

please download the latest version of Sitemap generator. This problem is fixed.

apaluch, thank you for assistance in fixing the issue! :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #13 on: January 21, 2006, 03:59:31 PM »
Hmmmm, still having problem. It worked twice and now when I manually crawl it never ends and again my php.exe thread is sitting at about 40% :'(

apaluch

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Stops Working
« Reply #14 on: January 21, 2006, 04:57:50 PM »
Sorry, head space problems on my part. Seems to be working OK. I like the sitemap.html feature and that we can template it.

Good Work!  ;)
Andy

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2