XML Sitemaps Generator

Author Topic: Bad links and indexing the forum  (Read 17138 times)

nick12

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Bad links and indexing the forum
« on: December 23, 2007, 02:38:00 PM »
Hi

I have just started using the sitemap but am getting 15 broken links listed all with an & at the end
directory/&
otherdirectory/&

and I can't find the links on the referring page

Also I have a forum with nearly 70,000 posts, I've currently set the sitemap to ignore forum/ because in the past sitemaps have tried listing hundreds of thousands of pages (like each and every way to view each post) I'm using invision power board, does anyone know a way of setting the sitemap up to crawl the forum without listing every possible way to view a page?

Thanks
Nick

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Bad links and indexing the forum
« Reply #1 on: December 23, 2007, 09:07:19 PM »
Hello,

1. please PM me your generator URL so that I can check it.

2. you can use "Do not parse" and "Excclude URLs" options for that. For instance you can add this to both settings:
Code: [Select]
sort=and that will exclude all pages that have "sort=" parameter attached.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

nick12

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Bad links and indexing the forum
« Reply #2 on: January 10, 2008, 04:10:32 PM »
Hi admin

Sorry for the delay in replying

I think the & problem is down to my email being encoded, it looks like

Code: [external links are visible to admins only]
<a href="&#109;&#97;&#105;&#108;&#116;&#111;&#58;%6E%69%63%6B%40%74%68%65%6D%6F%64%65%6C%73%63%6C%75%62%2E%63%6F%2E%75%6B&#63;&#83;&#117;&#98;&#106;&#101;&#99;&#116;&#61;Contact%20from%20TheModelsClub.Net">Nick</a>
Thanks for the tip about the forum, I'll try that :D

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Bad links and indexing the forum
« Reply #3 on: January 10, 2008, 11:49:51 PM »
Yes, that's right - it is related to an encoded mail link.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

nick12

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: Bad links and indexing the forum
« Reply #4 on: January 17, 2008, 12:16:44 AM »
It seems odd that it only picks up the 15 broken links as it is at the bottom of every page on the main site

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2