Template not being used in sitemap.html file
« on: January 19, 2006, 02:37:45 PM »
I'm using the new version of XML Sitemap. I really like the changes you have incorporated into the software but I am having a small problem.

I have modified the sitemap_tpl.html file but for some reason, the template is not being used for the sitemap.html output. The file always displays with the default template. Any ideas?

Thanks,
Stretchr
\"It\'s a small world...
But I wouldn\'t want to paint it!\"
Stephen Wright
Re: Template not being used in sitemap.html file
« Reply #1 on: January 19, 2006, 03:50:20 PM »
Hello Stretchr,

please make sure that file permissions are set correctly for output file. Please also check if generator copyright message is unchanged in the sitemap template.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Template not being used in sitemap.html file
« Reply #2 on: January 19, 2006, 04:02:05 PM »
Hello Stretchr,

please make sure that file permissions are set correctly for output file. Please also check if generator copyright message is unchanged in the sitemap template.

That may be the problem. I put in a javascript so that the year was always updated so I modified the copyright a bit. I try to do this with all files so that I don't have to update the date on a bunch of pages at the end of each year. It's strange because I tried this modification on another site template and it worked fine.

FYI, here's the modification I wish to use:
Code: [Select]
<div id="copyright">
HTML Site map Generated by <a href="http://www.xml-sitemaps.com" target="_blank">XML Sitemaps</a>
|
&copy; <a href="http://www.xml-sitemaps.com" target="_blank">XML Sitemaps</a> -
<script language = 'JavaScript' type="text/javascript"> type="text/javascript"
now = new Date
theYear=now.getYear()
if (theYear < 1900)
theYear=theYear+1900
document.write(theYear)
</script>
All Rights Reserved<br>
<br style="clear:both;"/>
</div>

I don't suppose you would consider switching to something like this for the sake of convenience?

Also, I don't see anywhere in the documentation where it addresses permissions on the template file. I already have all the other permissions assigned appropriately.

Thanks,
Stretchr
« Last Edit: January 19, 2006, 04:11:27 PM by Stretchr »
\"It\'s a small world...
But I wouldn\'t want to paint it!\"
Stephen Wright
Re: Template not being used in sitemap.html file
« Reply #3 on: January 19, 2006, 04:11:08 PM »
Oops, I just saw this:
Code: [Select]
<!--
PLEASE NOTE!
You are NOT allowed to remove and/or modify the copyright notice below.
Thank you!
www.xml-sitemaps.com
-->

Sorry. No harm intended.

Cheers,
Stretchr :-[
\"It\'s a small world...
But I wouldn\'t want to paint it!\"
Stephen Wright
Re: Template not being used in sitemap.html file
« Reply #4 on: January 19, 2006, 05:56:32 PM »
Hello Stretchr!

Basically the required part is the link, this is what the script is looking for:
<a href="http://www.xml-sitemaps.com">XML Sitemaps</a>

So, if you will have the code specified above in the template, it should work correctly.

Quote
Also, I don't see anywhere in the documentation where it addresses permissions on the template file.
I meant the permissions for output file, not the source template. :)

Quote
Sorry. No harm intended.
No problem, we just didn't stressed this point in the documentation. :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Template not being used in sitemap.html file
« Reply #5 on: January 19, 2006, 09:40:28 PM »
Hello Stretchr!

Basically the required part is the link, this is what the script is looking for:
<a href="http://www.xml-sitemaps.com">XML Sitemaps</a>

So, if you will have the code specified above in the template, it should work correctly.


I modified it by putting in
Code: [Select]
target="_blank". Could that be the problem?

Thanks
\"It\'s a small world...
But I wouldn\'t want to paint it!\"
Stephen Wright
Re: Template not being used in sitemap.html file
« Reply #6 on: January 19, 2006, 09:51:44 PM »
Yes, that's it. Please try the new generator 2.0.1 - it should work in this case too.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Template not being used in sitemap.html file
« Reply #7 on: January 20, 2006, 12:34:04 AM »
Yes, that's it. Please try the new generator 2.0.1 - it should work in this case too.

You were right, that is what was causing it. I'll give 2.01 a try. Thank you!

Stretchr
\"It\'s a small world...
But I wouldn\'t want to paint it!\"
Stephen Wright
Re: Template not being used in sitemap.html file
« Reply #8 on: January 20, 2006, 01:24:24 PM »
Hi Stretchr,

the copyright message in the html sitemap is not required (but appreciated :) ) now with the current version of Sitemap Generator (you may need to download it again to get the latest code).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.