XML Sitemaps Generator

Author Topic: Some links not appearing in my Sitemap ?????  (Read 20346 times)

wej

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Some links not appearing in my Sitemap ?????
« on: February 17, 2008, 03:10:06 AM »
I have some url links ( over 300 of them) that are not showing up in the results of a crawl.

Is this becase the links that are not "discovered" are listed in a pull down/options list??


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Some links not appearing in my Sitemap ?????
« Reply #1 on: February 17, 2008, 08:10:01 PM »
Hello,

yes, in case if pages are accessible *only* with submitting web forms (like select input field) or javascript, they are not crawled. I recommend you to duplicate the links in html code with  <a> tag.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

wej

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Re: Some links not appearing in my Sitemap ?????
« Reply #2 on: February 18, 2008, 01:12:28 AM »
Thank you for your response.
I have now tried that.  I moved all the urls to <a href="full URL address">Public Name </a> fields in [external links are visible to admins only].
They work when selected individually  but the crawl did not add them to the sitemap.html?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Some links not appearing in my Sitemap ?????
« Reply #3 on: February 18, 2008, 08:04:30 PM »
Is there a link to list_of_locations.html page somewhere on your site tool?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

wej

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Re: Some links not appearing in my Sitemap ?????
« Reply #4 on: February 19, 2008, 12:11:27 AM »
Yes at the foot of the links page on the links tab on the front page.
At the moment it is just a test page as a list of <a>...</a>' s and I will add a proper header and better layout later.

wej

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Re: Some links not appearing in my Sitemap ?????
« Reply #5 on: February 19, 2008, 08:05:43 AM »
Now O.K.   Moved all links to a "visible standalone page" ( [external links are visible to admins only] ) and now in sitemap.

Thank you for an excellent product ( it does what it says on the packet ) and first clas technical support.

Wej Parry
yellohire.com

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Some links not appearing in my Sitemap ?????
« Reply #6 on: February 20, 2008, 09:18:53 PM »
Great! :)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

mesothelioma

  • Guest
Re: Some links not appearing in my Sitemap ?????
« Reply #7 on: February 21, 2008, 02:19:55 AM »
I have some url links ( over 300 of them) that are not showing up in the results of a crawl.

Is this becase the links that are not "discovered" are listed in a pull down/options list??



I think the sitemap generator only indexes a certain amount of pages fo free

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2