XML Sitemaps Generator

Author Topic: Crawling help.  (Read 58751 times)

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Crawling help.
« on: February 16, 2006, 04:58:27 PM »
Hi,

First time here.
I have set everything up correctly (I think) I ran the crawling section, it was running for over an hour and then nothing. Nothing at all has changed. I created sitemap.xml in public_html bit there is nothing in it. Any ideas.


Regards
Jon

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #1 on: February 16, 2006, 05:31:01 PM »
Hello Jon,

have you seen the progress indicated when you started the sitemap crawler?
Also, please check the "data/" folder in your sitemap generator directory - do you haev any files created there?
« Last Edit: February 19, 2006, 12:27:40 AM by admin »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: Crawling help.
« Reply #2 on: February 16, 2006, 05:36:37 PM »
Hi admin,

Wow !! Fast reply, thankyou.

Nothing was placed into the /data/ location.

As the progress, I made sure that the option for not interupting it was on. On going back to check it all was working and it was crawling. Then when I checked for the last time I was taken back to the "start Crawling" page, nothing had chenged.  :-[

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #3 on: February 16, 2006, 08:00:30 PM »
Hi,

could you please let me know your Generator instance URL in Provate Message so that I can take a look?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: Crawling help.
« Reply #4 on: February 16, 2006, 08:03:35 PM »
Just sent it  ;)

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: Crawling help.
« Reply #5 on: February 17, 2006, 10:09:50 AM »
Hi Admin,

With reference to the PM you sent me. No, I dont have access, any other ideas?

Regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #6 on: February 17, 2006, 03:07:43 PM »
Hello,

I suggest you to narrow the scope of pages included into sitemap using "Do not parse URLs" and "Exclude URLs" options.
For instance enter the following in both settings:
Quote
newreply.php
sendmessage.php
to skip all newreply.php?xxx pages on your site (that are realy not required in sitemap)
Similar for others non-important pages.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: Crawling help.
« Reply #7 on: February 18, 2006, 05:22:13 PM »
Thanks,

I have excluded some of the links and it crawled nicely.

Any ideas what this is.?

When in the Analyze area I get this error:


Warning:  ksort() expects parameter 1 to be array, null given in /****/*****/*****/*****/pages/page-analyze.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 60

Warning:  Invalid argument supplied for foreach() in /*****/*****/*****/*****/pages/page-analyze.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 62

When trying to Download the xML file I get this:


System does not support the specified encoding. Error processing resource '[external links are visible to admins only].***********.com/sitemap.xml'. Line...

<?xml version="1.0" encoding="iso-8859-1"?>

Any ideas on these issues?
******* = replacing my data.


Kind regards
« Last Edit: February 19, 2006, 04:55:10 PM by NOJ75 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #8 on: February 19, 2006, 12:28:27 AM »
Great!

As for this issue, please make sure that you have set correct permissions for your data/ folder (the script should be able to write to it).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

NOJ75

  • Registered Customer
  • Approved member
  • *
  • Posts: 7
Re: Crawling help.
« Reply #9 on: February 19, 2006, 10:18:19 AM »
Hi,

Thanks again.

i already have the permissions set on the data file to CHMOD 777

Any other ideas?

Regards

maxiwebhost

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Crawling help.
« Reply #10 on: February 19, 2006, 04:30:37 PM »
Hi,
We just bought the script and i am also experience the same error by "Analyze":

Code: [external links are visible to admins only]
Warning:  ksort() expects parameter 1 to be array, null given in /XXXX/XXXX/XXXX/XXXX/pages/page-analyze.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 60

Warning:  Invalid argument supplied for foreach() in /XXXX/XXXX/XXXX/XXXX/pages/page-analyze.inc.php(2) : eval()'d code(1) : eval()'d code(1) : eval()'d code on line 62

Any ideas?


NOTE: Install path removed for security convenience.


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #11 on: February 19, 2006, 08:22:39 PM »
NOJ75,  maxiwebhost,

please let me know the URL of your generator instance in Private Message so that I can check that.

Thank you!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Crawling help.
« Reply #12 on: February 21, 2006, 12:57:50 AM »
Hello,

Update: the issue with analyze sitemap feature has been fixed in Sitemap Generator v2.1.
Please download the updated version to resolve the problem.

Thank you for reporting!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

maxiwebhost

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Crawling help.
« Reply #13 on: February 21, 2006, 09:32:24 AM »
Thanks for your effort.
Installed the new version but still the same error in "Analyze".

The line are now 61 and 63.

maxiwebhost

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Crawling help.
« Reply #14 on: February 21, 2006, 10:04:11 AM »
Forget my previous post please.
I regenerated a map and now everythings are working well.
Thanks for the good work :D

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2