XML Sitemaps Generator

Author Topic: Sitemap Not Reflecting Entire Site...?  (Read 19119 times)

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Sitemap Not Reflecting Entire Site...?
« on: April 18, 2008, 02:14:03 PM »
Hello,

I have a site with a forum, a news section, and an articles section.  Only the forum section seems to be showing up on the sitemap.  The other sections are not there.  The sections not showing up are powered by Wordpress. 

The sites are located in my site like:

[external links are visible to admins only]
[external links are visible to admins only]
[external links are visible to admins only]

Any idea why they're not in the sitemap and how I can get them to update?

Thanks.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #1 on: April 18, 2008, 09:11:07 PM »
Please PM me your generator URL so that I can check that.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Re: Sitemap Not Reflecting Entire Site...?
« Reply #2 on: April 21, 2008, 03:20:10 PM »
URL sent via PM. 

By the way, now I notice when I view it in the software's interface via the the "View Sitemap" tab it comes up fine, but when I try to view it directly at the sitemap.xml it shows an error:

Quote
XML Parsing Error: junk after document element
Location: [external links are visible to admins only]
Line Number 25, Column 2:   <div class="tborder" style="margin-top: 0;">
--------^

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #3 on: April 21, 2008, 03:37:34 PM »
Replied to your PM.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Re: Sitemap Not Reflecting Entire Site...?
« Reply #4 on: April 22, 2008, 08:58:32 PM »
[external links are visible to admins only]
Replied to your PM.

Got your reply but it's still not working.   ???

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #5 on: April 22, 2008, 09:27:15 PM »
Your homepage (domain.com) is redirected to the forum (domain.com/forum/), so your forums URL is assumed to be a starting page and all URLs outside of the forum folder are not crawled.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Re: Sitemap Not Reflecting Entire Site...?
« Reply #6 on: April 24, 2008, 07:43:19 PM »
Oooooooo-kay, well that's not very helpful.  I'm not sure why your software has to assume that.  So how can I fix it so they get crawled without moving everything from where I want it?  Will it work if I use a different kind of redirect?  Or add some code someplace?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #7 on: April 24, 2008, 09:38:27 PM »
You can create a small start.html page in domain root with a html link to your forum and specify domain.com/start.html as starting URL.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Re: Sitemap Not Reflecting Entire Site...?
« Reply #8 on: April 25, 2008, 01:27:05 PM »
[external links are visible to admins only]
specify domain.com/start.html as starting URL.

Specify it where?  How do I do that?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #9 on: April 25, 2008, 10:55:35 PM »
In sitemap generator configuration (the first option).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

jakesterz

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 10
Re: Sitemap Not Reflecting Entire Site...?
« Reply #10 on: April 28, 2008, 02:53:08 PM »
That didn't work.  I even put specific links for the parts of my site not being mapped and it's still not crawling them.   >:(


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Sitemap Not Reflecting Entire Site...?
« Reply #11 on: April 28, 2008, 09:38:13 PM »
Please PM me your generator login (the login you sent earlier doesn't seem to work anymore).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2