XML Sitemaps Generator

Author Topic: Can't run generator  (Read 20931 times)

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Can't run generator
« on: September 11, 2008, 07:10:01 PM »
I've uploaded all the files to the server but I just get a internal server 500 message.  Any idea what's gone wrong?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #1 on: September 12, 2008, 05:20:33 PM »
Hello,

are you on Windows or Linux/Unix server? Did you change any files permissions?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #2 on: September 12, 2008, 07:12:19 PM »
[external links are visible to admins only]
Hello,

are you on Windows or Linux/Unix server? Did you change any files permissions?

Linux and I believe so. 

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #3 on: September 13, 2008, 08:51:13 PM »
Try to remove files and reinstall sitemap generator - do not change permission yet and open it in browser.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #4 on: September 14, 2008, 01:49:26 PM »
[external links are visible to admins only]
Try to remove files and reinstall sitemap generator - do not change permission yet and open it in browser.

Ok... done that... now what?

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #5 on: September 14, 2008, 03:00:42 PM »
Now sorted. Just need to work out what to do with the xml file.  Is it just a case of telling Google about it?

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #6 on: September 15, 2008, 09:09:22 PM »
Right... It's now running but it keeps stopping.  I check every 10 minutes or so, even if it's supposedly running in background and it's always stopped but reporting that loads more pages are still to be done.  I then have to restart it. It's been going on for 2 days now.  It's at level 5.
« Last Edit: September 15, 2008, 09:35:03 PM by p.mawdesley »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #7 on: September 15, 2008, 10:07:24 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #8 on: September 23, 2008, 07:05:48 PM »
Hi Still not really getting very far with this as it times out even with lengthy settings.  How do I remove ther forum from the sitemap as that may be the cause?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #9 on: September 24, 2008, 08:16:50 PM »
You should add it to "Exclude URLs" option, for instance if your forum is in domain.com/forums/ folder, you should add:
Code: [Select]
forums/
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #10 on: September 26, 2008, 09:24:10 PM »
This is still dragging on.  I have removed the forums but I have about 6000 shtml article pages on my site but for some reason only 11 are being added to the Sitemap (these 11 are the main category links).  It's ignoring all the articles.  What's going wrong?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #11 on: September 30, 2008, 12:17:27 AM »
Hello,

could you please PM me your generator URL and an example URL that is not included in sitemap and how it can be reached from homepage?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

p.mawdesley

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: Can't run generator
« Reply #12 on: October 01, 2008, 11:46:59 AM »
Hi

I've PM'd the details a couple of times but not heard back.  Just checking you got it.
Cheers
Paul

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10623
Re: Can't run generator
« Reply #13 on: October 01, 2008, 09:25:48 PM »
Hello,

the article link points to non-www domain, so it cannot be included in the same sitemap as starting URL (www.domain.com). You should specify non-www as starting URL as well.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

craigparker

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: Can't run generator
« Reply #14 on: October 08, 2008, 03:28:34 PM »
I am having a similar problem, I have installed the script following the guide, set all permission and I can access the interface fine but when i change option or edit things and press save the page jsut refreshes and nothing changes, same occurrence if i run the crawler, page just goes back to how it was.

No error or permission issue just nothing happening, any ideas?

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2