XML Sitemaps Generator

Author Topic: Browser times out before crawl starts  (Read 15917 times)

bstuff

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Browser times out before crawl starts
« on: October 11, 2008, 02:09:46 PM »
Hi,

I have just installed the standalone generator and attempting to crawl the site for the first time.

When I click run I get "Please wait. Sitemap generation in progress..." but the box below remains blank. Then after a few minutes I get an error message "Internet Explorer cannot display the webpage"

Any help appreciated.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Browser times out before crawl starts
« Reply #1 on: October 13, 2008, 06:28:24 AM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

bstuff

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Browser times out before crawl starts
« Reply #2 on: October 13, 2008, 11:46:19 AM »
max_execution_time = 30
memory_limit = 8M

What numbers do you suggest I try?

Do I need to restart apache or anything to make the changes take effect?

Will this change affect server performance noticeably?

thanks for the help.
« Last Edit: October 13, 2008, 11:56:03 AM by bstuff »

bstuff

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Browser times out before crawl starts
« Reply #3 on: October 13, 2008, 12:08:20 PM »
I tried execution time =45 and then =60

I tried memory_limit = 12M and then 16M

then I tried setting them both to 60 and 16M at the same time


No luck.

How high should I go with trying?


*EDIT: I've tried it up to 180 seconds and 128M now and that doesn't work either.

I did stop and start apache after each change.
« Last Edit: October 13, 2008, 12:36:28 PM by bstuff »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Browser times out before crawl starts
« Reply #4 on: October 14, 2008, 09:58:20 AM »
Hello,

replied to your email message.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

bstuff

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: Browser times out before crawl starts
« Reply #5 on: October 14, 2008, 11:11:03 AM »
[external links are visible to admins only]
Hello,

replied to your email message.

Ok it's set back at 120 seconds and 128mb if you would like to have another look.


I just ran it from the command line and the crawl completed.... but it still does not work through the browser interface.

« Last Edit: October 14, 2008, 11:15:00 AM by bstuff »

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2