non-latin chars in url appear as weird symbols
« on: November 15, 2008, 01:37:51 PM »
Hello,
first of all i'd like to thank you for the great product... i'll probably need the above 500 links soon, but just wanted to understand somthing before...
i have non latin chars in my urls, it is important for me to have does.
when i try to create the site maps, all the non-lating letters are changed to weird symbols, and the urls in the map looks somthing like this:
www.mysite.com/”סר˜™ם/videodirectlink/  ???
is that ok? i tried to enter such an address but couldn't, and got 404 page.
is it possible to turn the symbols to real letters?
thanks,
Yandos.
Re: non-latin chars in url appear as weird symbols
« Reply #1 on: November 15, 2008, 07:31:27 PM »
Hello,

as per xml sitemaps protocol, the links are urlencoded in sitemap: http://sitemaps.org/protocol.php
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: non-latin chars in url appear as weird symbols
« Reply #2 on: December 06, 2010, 03:31:22 PM »
Dow you think that it is safe to provide a site with such urls?

http://www.texnikosnet.gr/index.php/”ια†ημίƒει‚/•νημερ‰„ικά-†ρθρα/”ια†ημ郄εί„ε-ƒ„ο-TexnikosNET.gr.html

Will these be decoded before used by Google?

Regards, Panagiotis
Re: non-latin chars in url appear as weird symbols
« Reply #3 on: December 06, 2010, 09:47:52 PM »
I've updated online generator, please check the sitemap now.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: non-latin chars in url appear as weird symbols
« Reply #4 on: December 29, 2010, 10:03:26 AM »
Great! Now it seems that url encoding is OK but free on-line version only includes 8 entries into site map file. Why is that? Can you please check it on my site? http://www.texnikosnet.gr

I tried to install standalone demo version on my site getting following error report:

An error occured
There was an error while retrieving the URL specified: http://www.texnikosnet.gr/
HTTP headers follow:
Wed, 29 Dec 2010 09:57:13 GMT
Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.9
PHP/5.2.9
CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
/index.php?lang=el
0
close
text/html
HTTP output:


I'm willing to proceed purchasing unlimited version but I need you to ensure me that it will work on sites like this one: http://www.texnikosnet.gr/

Thank you in advance.

Regards, Panagiotis
Re: non-latin chars in url appear as weird symbols
« Reply #5 on: December 29, 2010, 10:35:08 AM »
Hello,

looks like all pages are redirected to "index.php?lang=el" on your site, you can check it here: http://www.xml-sitemaps.com/http-headers-viewer.html?op=http-headers-viewer&go=1&pageurl=http%3A%2F%2Fwww.texnikosnet.gr%2Findex.php%2F%CE%9D.-%CE%9B%CE%B1%CF%83%CE%B9%CE%B8%CE%AF%CE%BF%CF%85%2F&se=xmlsitemaps&submit=View
Response Code    HTTP/1.1 303 See Other
Location    /index.php?lang=el
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: non-latin chars in url appear as weird symbols
« Reply #6 on: December 29, 2010, 12:07:19 PM »
Thank you for your prompt reply.

How is it possible? If you visit the site http://www.texnikosnet.gr and hover mouse on links, you will notice on browser's status bar that each url starts with "index.php" followed by one or more path elements, for example http://www.texnikosnet.gr/index.php/%CE%9D.-%CE%91%CF%84%CF%84%CE%B9%CE%BA%CE%AE%CF%82/%CE%94.%CE%94.-%CE%91%CE%B8%CE%B7%CE%BD%CE%B1%CE%AF%CF%89%CE%BD/%CE%95%CE%BB%CE%B1%CE%B9%CE%BF%CF%87%CF%81%CF%89%CE%BC%CE%B1%CF%84%CE%B9%CF%83%CE%BC%CE%BF%CE%AF-%CE%91%CE%B3%CE%B3%CE%B5%CE%BB%CF%8C%CE%BA%CE%B1%CF%83%CF%84%CF%81%CE%BF/

I'm probably missed something, can you please help me more on this?

Regards, Panagiotis
Re: non-latin chars in url appear as weird symbols
« Reply #7 on: December 29, 2010, 10:47:59 PM »
The redirect is sent via http header, as you can see using our http viewer with link I posted above.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: non-latin chars in url appear as weird symbols
« Reply #8 on: December 30, 2010, 09:57:42 AM »
Thanks again for your time. I'm not that experienced to understand the problem, I was surprised because I click on links and get directed to the proper page!

What do you think I could do to fix this? Site is based on Joomla! 1.5 with sh404sef component converting normal "&" based urls to search engine friendly by creating urls using section, category and title.

Regards, Panagiotis
Re: non-latin chars in url appear as weird symbols
« Reply #9 on: December 30, 2010, 12:29:42 PM »
You should contact your site developer or webmaster to correct that.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.