XML Sitemaps Generator

Author Topic: generator not mapping my wordpress blog  (Read 15613 times)

edb

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
generator not mapping my wordpress blog
« on: December 27, 2008, 11:38:29 PM »
When I run the unlimited sitemap generator on my site, [external links are visible to admins only]
it appears to crawl the /blog/ area according to what it shows in the status,
but none of the sitemaps contain any info about my /blog/ area.
And I get no broken links showing.
When I run the Free Online Sitemap Generator, the /blog/ area does show up, along
with some broken links in that area.
I've checked my robots.txt files and .htaccess files and everything seems okay there.
I've turned off the Google XML Sitemaps plugin on WordPress, and deleted its sitemap.xml,
but that doesn't change anything.

Is there a configuration setting I've missed?

My generator is at /XMLsitemap/

Thanks for your help.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: generator not mapping my wordpress blog
« Reply #1 on: December 29, 2008, 12:09:48 AM »
Hello,

you have the following in html code on your blog pages:

<meta name='robots' content='noindex,nofollow' />

you should remove that.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

edb

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: generator not mapping my wordpress blog
« Reply #2 on: December 29, 2008, 03:08:33 AM »
Okay,
I removed that (my dumb mistake, I had the Privacy setting in Wordpress set wrong).
So the nofollow is gone from my blog pages now.
But it doesn't seem to fix the problem. Still getting the same number of pages indexed.
And it doesn't explain why the Online Generator follows
into my blog, but the unlimited generator skips it.

I also tried cleaning up my robots.txt file to allow everything, but that didn't fix it.
I'm still stumped!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: generator not mapping my wordpress blog
« Reply #3 on: December 29, 2008, 08:55:35 PM »
I've changed starting URL from www.domain.com to domain.com and that worked (since your blog uses non-www domain).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

edb

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: generator not mapping my wordpress blog
« Reply #4 on: December 30, 2008, 05:44:28 AM »
Wow, thanks!
I must've looked at that a dozen times and didn't notice the www.
I think the software automagically filled in the field and I didn't double
check for that. As a rule I don't use the www on my sites.

Thank you very much!

Ed

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2