XML Sitemaps Generator

Author Topic: not indexing pages  (Read 18064 times)

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
not indexing pages
« on: January 22, 2009, 09:31:00 PM »
I have installed on a few websites without a problem, but on one website it is not indexing pages.  It produces site maps but only shows the homepage and nothing else.  The site is [external links are visible to admins only]

thanks.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing pages
« Reply #1 on: January 22, 2009, 10:24:35 PM »
Hello,

it looks like all your internal pages have domain name with altered character case, so it's considered to be a different domain, please check our search engine bot simulator: http://www.xml-sitemaps.com/se-bot-simulator.html?op=se-bot-simulator&go=1&pageurl=http%3A%2F%2Fwww.thelawyerclassifieds.com%2F&se=googlebot&submit=Start
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #2 on: January 24, 2009, 04:22:33 AM »
Does that mean that I cannot use your software on the website?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing pages
« Reply #3 on: January 25, 2009, 04:45:08 PM »
No, it will work fine, you should just correct your internal links to make sure that domain name is in lower case. That will also help to avoid any issues with crawling of your site by search engines.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #4 on: January 26, 2009, 05:28:03 AM »
I corrected the URLs to be all lowercase and logged into my site map generator page and found that it was hacked.  It has an image and says at the top:

Hacked By CyBeRNeTiC For Muslims

I guess I should start this is a new thread, so I will do so now.
« Last Edit: January 26, 2009, 05:30:58 AM by philesq »

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #5 on: January 26, 2009, 05:36:09 AM »
I posted a message about sitemap generator not indexing my site which apparently had to do with uppercase URLs.  I corrected the URLs to be all lowercase, logged into my site map generator page and found that it was hacked.  It has an image and says at the top:

Hacked By CyBeRNeTiC For Muslims

I just looked and the file config.inc.php that nothing on it but a link to the image and the hacker's message.
« Last Edit: January 26, 2009, 05:43:22 AM by philesq »

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #6 on: January 26, 2009, 05:50:08 AM »
The URLs are now all lower case, and the hacker problem was fixed, but it is still not indexing my site.  To fix the hacker problem, I deleted the file config.inc.php on the server and uploaded the copy I had.  I changed the chmod setting to 777 and crawled the site.  It is still not saying any of the pages.  This time, after crawling, I changed the security setting to 644.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing pages
« Reply #7 on: January 27, 2009, 03:29:51 AM »
Hello,

you have the following at the top of your pages:
<base href="http://www.TheLawyerClassifieds.com/">

please change it to:
<base href="http://www.thelawyerclassifieds.com/">



re: hacking problem
Please make sure to set permissions for config file back to 0644 after completing configuring of sitemap generator (as described in installation instructions).

Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #8 on: January 28, 2009, 06:04:06 PM »
You stated:
you have the following at the top of your pages:
<base href="[external links are visible to admins only]">

please change it to:
<base href="[external links are visible to admins only]">

I do not see that the domain is appearing in uppercase letters.  I tried using both IE 6 and Firefox.  I even try typing the domain with uppercase letters as you indicated above and it changes to lowercase letters.  Following is the URL I see for the category Accident & Injury Lawyers:
[external links are visible to admins only]

I see lower case letters for all categories.

philesq

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 12
Re: not indexing pages
« Reply #9 on: January 28, 2009, 06:59:11 PM »
It works now.  I went to the configuration section and added www. to the field Starting URL: and the field Your Sitemap URL:


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing pages
« Reply #10 on: January 28, 2009, 09:53:27 PM »
Great, I'm glad that worked!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2