XML Sitemaps Generator

Author Topic: SG Won't initialize in admin interface  (Read 13734 times)

ed.wesch1

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
SG Won't initialize in admin interface
« on: April 08, 2009, 04:15:26 AM »
I have a completely fresh PHP install (put it on for this program) using the default php.ini-recommended settings.  I installed SG locally, so there are no file permissions issues - everything is RW in Windows 2003.  The admin interface doesn't take my changes.  It says they are saved, but if I leave and come back the defaults are back.

I tried manually editing config.inc.php and *some* of the settings changed.  I can alter for example the max execution time and the max pages crawled (and others) but the initial url, sitemap name and sitemap url remain unchanged in the interface no matter what I put into the file manually.

The defaults that SG plugs in are subtly wrong.  For example:
My sitemap url is listed by the program as

[external links are visible to admins only]/sitemap.xml

And when I attempt to crawl the page with the changes I have manually made, I get this error:

There was an error while retrieving the url specified: [external links are visible to admins only]/
Error Message: Error opening socket to [external links are visible to admins only]

Note the \/ at the end of the first line on the error message.  Same thing as on the sitemap xml that SG defaults to.

I get the same errors running it directly on the server desktop as I do running it remotely from a browser window (its a dedicated server and I am running it as an administrator).

How do we get this fixed?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: SG Won't initialize in admin interface
« Reply #1 on: April 08, 2009, 10:54:53 PM »
Hello,

you should setup file permissions as described in installation instructions - in case if changes are not saved, currently write access is not allowed for config file. Since you are on Windows server, you should setup access via hosting control panel or via remote desktop, allowing write access for IUSR_* user.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ed.wesch1

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: SG Won't initialize in admin interface
« Reply #2 on: April 09, 2009, 08:54:40 PM »
If you look at my original post I already said all permissions are rw (read/write enabled) and I am accessing thru Remote Desktop as an administrator.  The files were downloaded directly to the server so no permissioning issues exist.  By default they are read/write.  This is a screen shot taken directly off the server via RD:



Its not the files.  Is there something in a default (manually installed) PHP install/config that would prevent it from writing to disk?  I am using the latest build of PHP.  PHPInfo() is at [external links are visible to admins only]

On paper the product looks perfect for our needs.  We've got a lot of domains we could use this product on, both on this server and more on others, but first we need to figure out this issue.

ed.wesch1

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: SG Won't initialize in admin interface
« Reply #3 on: April 09, 2009, 09:12:51 PM »
The above are only local file permissions.  Here are the IIS file permissions for the generator folder and the config file.  Note both are read/write from inside of IIS... so its not that the files aren't permissioned properly.  The permissions are good.  What else could it be?




XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: SG Won't initialize in admin interface
« Reply #4 on: April 10, 2009, 01:05:07 PM »
To set the permissions properly in Windows you should:
- right click on file or folder and open "Properties" dialog, like on your first screenshot
- open "Security" tab
- find IUSR_.. name in usergroups list (it might be called also "Internet guest account")
- allow "Full access" for it and press "Ok" button.

Repeat the same for other files (sitemap.xml, ror.xml, config.inc.php files + data/ folder).
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ed.wesch1

  • Registered Customer
  • Approved member
  • *
  • Posts: 4
Re: SG Won't initialize in admin interface
« Reply #5 on: April 14, 2009, 03:40:18 AM »
You were right.  The execution permission was not set to allow changes.  That fixed it.  I didn't have default usernames in the system but I was able to figure it out.  Thanks!  I'll set this thing on a test run asap.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2