XML Sitemaps Generator

Author Topic: Sitemap generating blank <loc></loc> causing Invalid URL  (Read 11678 times)

DecalCity

  • Guest
Sitemap generating blank <loc></loc> causing Invalid URL
« on: August 21, 2009, 10:43:42 AM »
Seems that this doesn't happen all the time. But it happens usually on automatic generations. I have had the sitemap generator manually started and it seems it does fine.

I have mine regenerated every week, once a week.

Here his a snippet of what it looks like in the sitemap.

Code: [Select]
  <url>
       <loc></loc>
       <lastmod>2009-08-20T06:26:53+00:00</lastmod>
       <changefreq>weekly</changefreq>
       <priority>0.5000</priority>
  </url>


I have sixteen of these in the last sitemap generation.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #1 on: August 22, 2009, 02:53:58 AM »
Hello,

if you have "Minimize script memory usage:" option enabled, try to disable it.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

DecalCity

  • Guest
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #2 on: August 23, 2009, 10:09:27 PM »
Well it was checked, so I unchecked it. Now the script won't complete. I have to keep going back and restart it where it left off.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #3 on: August 24, 2009, 06:12:31 AM »
You should increase memory_limit and max_execution_time settings in php configuration to address that.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

DecalCity

  • Guest
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #4 on: August 25, 2009, 01:09:08 AM »
Here are what my settings are set at.

memory_limit => 128M => 128M
max_execution_time is set at 6000 as well as max_input_time

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #5 on: August 25, 2009, 08:51:44 PM »
Ok, please try to increase them.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

DecalCity

  • Guest
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #6 on: August 26, 2009, 01:07:05 AM »
I have these settings in config of sitemap generator

Maximum execution time: 5000
Maximum memory usage: 125

Do I still need to increase it on the server?

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: Sitemap generating blank <loc></loc> causing Invalid URL
« Reply #7 on: August 26, 2009, 11:06:59 PM »
Yes, in some cases server just doesn't allow scripts to alter the settings, so you should update php configuration on the server.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2