Encoding problem with xml-sitemap
« on: February 03, 2010, 12:33:48 PM »
Hello
I purchased the Standalone XML Sitemap Generator a couple of mounths ago.
I didn't have any problem with your services until now.
But now, when I want to optimize the URLs of my website by SEF, I can't use the xml-sitemap services properly.
the problem is this :
 
my website is in persian (as a language) and charachters should set to UTF-8 .
When I submit a new sitemap for new URLs which have persian or arabic charachters in them, I see URLs in the sitemap like this:
 
[ External links are visible to forum administrators only ]:مدیریت
 
but the correct URL is this one :
 
[ External links are visible to forum administrators only ]
 
My Sitemap URL is :
[ External links are visible to forum administrators only ]
 
please help me to solve this problem.
 
Thanks.
MILAD SAFAEI
Re: Encoding problem with xml-sitemap
« Reply #1 on: February 03, 2010, 08:04:53 PM »
Hello,

replied to your email.
Oleg Ignatiuk
https://www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Encoding problem with xml-sitemap
« Reply #2 on: February 03, 2010, 08:37:56 PM »
Hi
Thanks for answer.
But do you mean there is no any problem even URLs don't display in xml sitemap properly ?
I added the sitemap to google webmastertools , so can I be sure that Google will see the URLs properly ?
I am waiting for your answer.
Thanks.
Re: Encoding problem with xml-sitemap
« Reply #3 on: February 04, 2010, 09:58:40 PM »
Yes.
Oleg Ignatiuk
https://www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Encoding problem with xml-sitemap
« Reply #4 on: February 10, 2010, 10:48:31 PM »
Hi
Thanks for guide.
But I have the problem yet.
Google doesn't see URLs properly.
You can see it here:
[ External links are visible to forum administrators only ]
As you see in the picture, URLs of my website, don't appear truly  in results of search engines.
Please help me to solve this problem in the xml sitemap.
Re: Encoding problem with xml-sitemap
« Reply #5 on: February 11, 2010, 10:46:20 PM »
Hello,

this is not related to a sitemap - that is how google sees your pages, i.e. Google does NOT include URLs from sitemap directly in index, it visits your pages anyway.
Oleg Ignatiuk
https://www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.