BUG: Unicode URLs don't work in paid version.
« on: March 16, 2010, 07:46:28 AM »
Sorry this is in the wrong category; I noticed my email was being published on the web and deleted my account before I realised I could turn it off (stupid me).


First, let me say how wonderful the app is. I've set it up on my websites with a cron job, and it's going to save hours and hours of my time. Wonderful! :)

I did have one little issue though...

Bug report:
I have a website that uses Japanese in the URLs, and the sitemap generated has corrupted these Japanese characters into latin characters. I've opened the sitemap in a unicode editor and it can't be converted back into Japanese characters. I write web pages in Japanese, so I know what should work.

Here's some URLS:
Site: http://www.japan-guest-house.com/
Sitemap: http://www.japan-guest-house.com/sitemap.xml

For a Japanese URL, go to this page:
http://www.japan-guest-house.com/house/43/
And click the link at the bottom of the page named "View large map for more...".

I hope you know how to fix it!

PS
If you want to make me a paid user account again so I can post on the correct forum, that would be great! :)
Re: BUG: Unicode URLs don't work in paid version.
« Reply #1 on: March 16, 2010, 08:37:41 AM »
Hello,

all links in xml sitemap are "urlencoded' according to sitemaps protocol: http://sitemaps.org/protocol.php
So, you should not open it in text editor, but submit to search engines instead to check that it's parsed correctly: https://www.google.com/webmasters/tools/dashboard
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: BUG: Unicode URLs don't work in paid version.
« Reply #2 on: March 16, 2010, 08:59:03 AM »
Oleg,

I've uploaded it to Google's webmaster tools and it seems to be working - I'll post here If I see any further errors.

Thanks for your help! Great tool!

Jonathan