XML Sitemaps Generator

Author Topic: sitemap not working  (Read 9104 times)

klaas

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
sitemap not working
« on: April 13, 2011, 06:08:55 AM »
hi
i bought the software 2 days ago, and untill now have been unsuccessfull.
first of all, the video sitemap (primary reason i bought this)
is totally useless, primary reason you want a sitemap is that it indexes the content of your site, we have 22.000 videos on our site, but none gets indexed.
you mention that it will only index embedded videos from youtube etc, what is the use of that, i want my content embedded not someone elses ???
so thats $5 wasted for a stupid add-in with no function

(i'm yet to look at the image add-on i bought also, but first testing showed an empty images sitemap also)

for the normal indexing, when run from cron or web,
it never writes a sitemap (well it does for a small number of url's like 5000 or so)
but when i let it crawl the entire site, it hangs

i'm on my own dedicated server btw,
i get 
Wed Apr 13 08:01:14 UTC+0200 2011: resuming generator (120 seconds with no response)
Wed Apr 13 07:59:14 UTC+0200 2011: resuming generator (121 seconds with no response)
Wed Apr 13 07:57:13 UTC+0200 2011: resuming generator (121 seconds with no response)
Wed Apr 13 07:55:12 UTC+0200 2011: resuming generator (121 seconds with no response)
Wed Apr 13 07:53:11 UTC+0200 2011: resuming generator (120 seconds with no response)
forever and the page hangs.

when running 'top' on the server, i can see that it really stopped (no extra httpd processes there.


XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: sitemap not working
« Reply #1 on: April 13, 2011, 12:27:52 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

klaas

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: sitemap not working
« Reply #2 on: April 13, 2011, 04:32:47 PM »
see php.ini settings below:
[root@p3 etc]# more php.ini|grep memory
memory_limit = 1024M      ; Maximum amount of memory a script may consume
[root@p3 etc]# more php.ini|grep execution
max_execution_time = 0     ; Maximum execution time of each script, in seconds
[root@p3 etc]#

attached is a screenshot of failing crawler

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: sitemap not working
« Reply #3 on: April 13, 2011, 08:39:21 PM »
Hello,

please let me know your generator URL/login in private message to check this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2