XML Sitemaps Generator

Author Topic: Only part of website is being indexed.  (Read 13330 times)

Emil_RDW

  • Approved member
  • *
  • Posts: 2
Only part of website is being indexed.
« on: May 17, 2011, 03:28:15 PM »
I see this is a common problem on this forum and I did try every possible solution posted but I still have not found a way to index all of my site.  The site is [external links are visible to admins only]  (please ignore the looks of the site as I did not create it  :o ) but anyway, for some reason I only get 9 links indexed out of close to 40.

I have a correct robots.txt, I have the META tags
Code: [external links are visible to admins only]
<meta name="robots" content="index,follow"> and I have no idea why it will not see the majority of the pages.

I even took the META information off one of the indexed pages to a page that is not being indexed and still nothing.

Any help would be very appreciated!

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: Only part of website is being indexed.
« Reply #1 on: May 17, 2011, 07:58:34 PM »
Hello,

you have your navigation links working with javscript, like:
<input onclick="window.location.href= 'rebuilt-truck-transmissions.html'">
which is not visible to bots.
You should have links with <a href="rebuilt-truck-transmissions.html"> to get them indexed.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

Emil_RDW

  • Approved member
  • *
  • Posts: 2
Re: Only part of website is being indexed.
« Reply #2 on: May 17, 2011, 08:26:52 PM »
Yeah I was afraid of that  :-\

Well I'll go change them and try again.

Thanks for the help!

-Emil

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2