XML Sitemaps Generator

Author Topic: There was an error while retrieving the URL specified.........  (Read 9778 times)

wdog6666

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
There was an error while retrieving the URL specified.........
« on: December 17, 2011, 01:31:34 PM »
I've been running the standalone XML-Sitemap since 2008 and it's suddenly started giving the error:

There was an error while retrieving the URL specified: [external links are visible to admins only]
HTTP headers follow:

HTTP output:


Re above, I've changed the site name to 'mysite'.
I've tried various fixes on this forum (i.e.www. and non www. etc) and I've just uploaded the latest version which generates the same error?

Although there's a few peeps on this forum who have a similar (or the same?) problem, the final post always seems to be an admin post saying:

Please PM me your generator URL/login.

With no follow up?

The only recent mod to the site they may be effecting the sitemap was we had an SSL cert installed, but, the 'normal' (i.e non SSL) should still run on port 80?

Also, the sitemap generates fine using the 'free' xml-sitemap generator on the xml-sitemap.com homepage.

Any pointers, help or info would be helpful........

Cheers!!

Jungle Bee

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Error while retrieving the url
« Reply #1 on: December 17, 2011, 05:54:34 PM »
When i start my site map crawling...it gives the following error:
------------------------------------------
There was an error while retrieving the URL specified: [external links are visible to admins only]
HTTP headers follow:
date: Sat, 17 Dec 2011 17:50:57 GMT
server: Apache
p3p: CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"
location: [external links are visible to admins only]
vary: Accept-Encoding
content-length: 0
connection: close
content-type: text/html

HTTP output:
----------------------------
What should i do...to fix this problem.....i am not able to generate even a single sitemap
Thanks

Jungle Bee

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: There was an error while retrieving the URL specified.........
« Reply #2 on: December 17, 2011, 06:03:59 PM »
I am having the exactly the same problem. Admin Please answer this quickly....and please in an open post so that everyone knows what happens in the end...
Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10625
Re: Error while retrieving the url
« Reply #3 on: December 17, 2011, 08:14:33 PM »

wdog6666,

please try to sepcify your server's IP address in generator configuration (there is a setting for that). Or try to set that setting to "127.0.0.1".

Jungle Bee ,

there seems to be a redirect from non-www to www domain, you should use www.domain.com as Starting URl for sitemap generator intead of just "domain.com".
« Last Edit: December 17, 2011, 08:22:47 PM by XML-Sitemaps Support »
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

wdog6666

  • Registered Customer
  • Approved member
  • *
  • Posts: 2
Re: There was an error while retrieving the URL specified.........
« Reply #4 on: December 17, 2011, 08:43:51 PM »
Thanks for the reply, I've changed the servers IP address to '127.0.0.1' and it works now!

For anyone trying this, the 'servers IP address' bit is in the 'advanced setting' bit at the bottom of the Configuration page (the IP box is labeled 'Use IP address for crawling:').

Cheers and have a good Xmas & new year!

Jungle Bee

  • Registered Customer
  • Approved member
  • *
  • Posts: 3
Re: There was an error while retrieving the URL specified.........
« Reply #5 on: December 18, 2011, 01:02:31 AM »
It worked for me....Thanks

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2