webmaster337

*
  • *
  • 4
  • Kung Fu!
Hi there, Just purchased your sitemap generator with the images sitemap add on.

We uploaded your xml sitemap generator to test and though it works pretty well, it's not properly indexing all the pages ( even though it seems to crawl them )

For example:
Pages indexed: 12
Pages crawled: 16

Now i can confirm the following. We created some new test pages.
test.html, test2.html, test3.html

And we ran sitemap generator to test, it does not index all 3 pages, it only indexes 1.

It also does not index 2 other urls on our website which are old and original urls. These urls are linked on homepage from menu and in homepage content area.

All urls are accessible from the homepage because each single url is linked to the Main menu.

We need all our urls indexed properly. Please help! Our site is built on Joomla.

Thanks very much
Hello,

could you please PM me your generator URL and an example URL that is not included in sitemap and how it can be reached starting from homepage?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

webmaster337

*
  • *
  • 4
  • Kung Fu!
Hi there, Thanks very much.

http://calligraphyalphabet.org/sitemap.xml

These 2 urls don't get indexed into the xml sitemap

http://calligraphyalphabet.org/fancy-calligraphy-alphabet-styles-from-m-to-z.html
http://calligraphyalphabet.org/gothic-calligraphy-alphabet-styles-from-m-to-z.html

( those 2 pages are linked directly from the homepage by the way in content and menu - 2 places )

and we created 3 test pages
http://calligraphyalphabet.org/test.html
http://calligraphyalphabet.org/test2.html
http://calligraphyalphabet.org/test3.html

Only http://calligraphyalphabet.org/test.html comes up in the sitemap.

Again all 3 test pages are linked from homepage menu as well.

We use XMAP sitemap component before and it properly indexes all the urls, you can see it here:
http://calligraphyalphabet.org/component/option,com_xmap/lang,en/sitemap,1/view,xml/

Please fix this issue and let me know what was the problem because we will install this on another site too and don't want to have the same problems.

Thanks very much for your help!

webmaster337

*
  • *
  • 4
  • Kung Fu!
Hi there again,

Had you had a chance to look at the problem as mentioned above?

Thanks
Hello,

I've added 1 second delay after each request and that helped.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

webmaster337

*
  • *
  • 4
  • Kung Fu!
Hey there,

Yes that seems to have indeed fixed up the problem. I appreciate your help sorting this out for us.

Thanks again and please have a great week.

Cheers