XML Sitemaps Generator

Author Topic: bug in generated sitemap.xml v2,5  (Read 30028 times)

admin45

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
bug in generated sitemap.xml v2,5
« on: November 25, 2006, 12:05:24 AM »
hi,
i am using the new version 2,5 and having these problems
the script generate the sitemap.xml wrong!
generated sitemap.xml begin with these lines :
<?xml version="1.0" encoding="UTF-8" ?>
*****xmlns="[external links are visible to admins only]" xmlns:xsi="[external links are visible to admins only]" xsi:schemaLocation="[external links are visible to admins only] [external links are visible to admins only]">

missing the - <urlset where ***** are placed above

also Individual attributes options are not working properly
our example in  Individual attributes :
?page=,2006-11-12,weekly,0.5
?mod=,2006-11-12,monthly,0.5
but the script gives URLs with these substings 1.0 priority
please take a look at [external links are visible to admins only] (fixed manually now)

as discribed in the new futures of the new version 2.5 robots.txt compliance can be turned on/off now with xs_robotstxt option in config file

i really can't see the xs_robotstxt  on my config file!


also the script is still not pinging google!
sorry for my bad english i hope you can solve this problem

thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: bug in generated sitemap.xml v2,5
« Reply #1 on: November 25, 2006, 12:25:59 AM »
Hello,

Quote
missing the - <urlset where ***** are placed above
Quote
also Individual attributes options are not working properly
Thank you for reporting!
This issue has been corrected, please download new Sitemap Generator v2.5.1




Quote
i really can't see the xs_robotstxt  on my config file!
It should be manually inserted into it:
Code: [Select]
    'xs_robotstxt' => '0',"0" means to disable, it's enabled by default when no setting is defined.

Quote
also the script is still not pinging google!
The pings should work fine, how do you check this?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

admin45

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: bug in generated sitemap.xml v2,5
« Reply #2 on: November 25, 2006, 12:39:35 AM »
Can i keep my config file when i download the fixed version?

>The pings should work fine, how do you check this?
i can see that on my google webmasters account i still see that the last download made by google of my sitemap.xml was 19 ours ago this is never happends before i used this script.
 google downloaded allways my sitemap after 3 minuts of pinging!
i used this script 5 or 6 times today and no downloads by google
regards,kimo
« Last Edit: November 25, 2006, 12:58:06 AM by admin45 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: bug in generated sitemap.xml v2,5
« Reply #3 on: November 25, 2006, 12:58:12 AM »
Quote
Can i keep my config file when i download the fixed version?
Yes, you can keep it.
Quote
i can see that on my google webmasters account i still see
Please let me know your generator ULR/login in private message so that I can check that.

Thanks!
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

admin45

  • Registered Customer
  • Approved member
  • *
  • Posts: 8
Re: bug in generated sitemap.xml v2,5
« Reply #4 on: November 25, 2006, 01:05:23 AM »
DONE!
THANKS

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2