Weird "glitched" characters in sitemap_images description
« on: June 15, 2012, 09:25:52 PM »
Hello, for reference I am using Wordpress on my website, images have "Titles", "Alternative Text", and a few images use "Captions".

In my sitemap_images, only SOME images have descriptions with weird characters in them. For instance:

"Galileo Scholar's Book Box Thumbnail"
"Sketch, "Marie-Therese Walter Coffée d'un Béret" 1927"
"Van Gogh's "Starry Night""

Any idea why/how this is happening, and how to correct it?

Thanks,
Michael

Re: Weird "glitched" characters in sitemap_images description
« Reply #1 on: June 16, 2012, 11:49:24 AM »
Hello,

sitemap generator uses "title" or "alt" attribute, whichever appear first in img tag.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Weird "glitched" characters in sitemap_images description
« Reply #2 on: June 16, 2012, 03:07:25 PM »
Yes, but why are the descriptions having these weird characters? It looks like it is displaying character html code instead of plain text. How to fix this?

For instance:
"Galileo Scholar's Book Box Thumbnail" ---> "Galileo Scholar's Book Box Thumbnail"
The ' is showing as "#039;"
Re: Weird "glitched" characters in sitemap_images description
« Reply #3 on: June 18, 2012, 04:00:38 PM »
What is an example page/image URL?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Weird "glitched" characters in sitemap_images description
« Reply #4 on: June 18, 2012, 07:05:25 PM »
Ok I kind of see what's going on.

Here is a example page:
http://www.bookboxshop.com/product/picasso-lady-sitting-in-chair/

The sitemap generator is filing the thumbnail instead of the full attachment image, and glitching with the alt text as well. For instance, it is putting this image in the sitemap:
http://www.bookboxshop.com/images/le-reve-the-dream-205x176.jpg
instead of: http://www.bookboxshop.com/images/le-reve-the-dream.jpg

Or both. It is also glitching with the alt text. What can I do?
Re: Weird "glitched" characters in sitemap_images description
« Reply #5 on: June 18, 2012, 07:20:25 PM »
Re: Weird "glitched" characters in sitemap_images description
« Reply #6 on: June 19, 2012, 04:17:45 PM »
According to images sitemap specs, it must include the images that is *embedded* on the page (i.e. thumbnail in your case)
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.
Re: Weird "glitched" characters in sitemap_images description
« Reply #7 on: June 19, 2012, 06:37:57 PM »
But how do I get rid of these html codes? Why is the generator generating these weird codes & symbols?
Re: Weird "glitched" characters in sitemap_images description
« Reply #8 on: June 19, 2012, 10:32:16 PM »
Hello,

please let me know your generator URL/login in private message to check this. It seems to work fine for me.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.