XML Sitemaps Generator

Author Topic: not indexing all pages  (Read 13180 times)

NetBarg

  • Approved member
  • *
  • Posts: 2
not indexing all pages
« on: June 17, 2012, 11:57:46 AM »
Hi,

We have encountered a problem, apparently the sitemap generator does not index all our pages and lots of pages are missed out.

I would appreciate your help and guid.

[external links are visible to admins only]

Regards,

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing all pages
« Reply #1 on: June 18, 2012, 03:02:05 PM »
Hello,

could you please PM me your generator URL and an example URL that is not included in sitemap and how it can be reached starting from homepage?
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

NetBarg

  • Approved member
  • *
  • Posts: 2
Re: not indexing all pages
« Reply #2 on: June 18, 2012, 07:59:13 PM »
for some reason it says im not allowed to send private massages, if you could send a quick email to admin{at}netbarg.com, i would be able to email you everything.
Regards

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing all pages
« Reply #3 on: June 19, 2012, 09:21:41 PM »
Sent.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

rominashanti

  • Approved member
  • *
  • Posts: 4
Re: not indexing all pages
« Reply #4 on: July 31, 2012, 07:10:14 PM »
Hi, I'm experiencing the same problem. I tried to make the sitemap with the free version and said there were more than 500 pages. I have the pro version now and only getting 390 pages in the sitemap. I check it and I'm sure there is a lot missing. Thanks!

rominashanti

  • Approved member
  • *
  • Posts: 4
Re: not indexing all pages
« Reply #5 on: August 01, 2012, 04:52:31 PM »
I tried to do the sitemap again and then got the right one. Now I have over 3,000 pages. Don't know what happened but apparently it is fixed!

shipman

  • Approved member
  • *
  • Posts: 1
Re: not indexing all pages
« Reply #6 on: August 27, 2012, 09:06:36 AM »
Hello,
Could you be so kind to help me.
Only 9 pages added to sitemap. What's reason of it? All links of site are working.

creativemix.com.ua

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing all pages
« Reply #7 on: August 27, 2012, 12:56:29 PM »
Looks like site stops responding after generator bot sends a number of requests in a row (http error 403 is returned). You can try on http://www.xml-sitemaps.com/indexadv.html page to start crawling with delays added after each request.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ron8

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 24
Re: not indexing all pages - us too!
« Reply #8 on: October 17, 2012, 01:55:12 AM »
Hi

We have been using SMG pro for some time

Now when I index a site it only adds 12 pages (top level) to the sitemap. It found 191 in the crawl.

The last sitemap we did had around 360 pages (which is what this one should have)

I didn't index the second tier ones (180 pages approx) or more pages linked from those (to make 360 total approx)

Why are they excluded? There are no robots.txt or no-indexes and everything should be well linked throughout the site.

Can I PM the login so you can check the config?

Thanks

Ron

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: not indexing all pages
« Reply #9 on: October 18, 2012, 12:03:44 PM »
Hello,

could you please PM me your generator URL and an example URL that is not included in sitemap and how it can be reached starting from homepage?
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

ron8

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 24
Re: not indexing all pages
« Reply #10 on: November 05, 2012, 02:57:17 AM »
Thanks Oleg
We have discovered that it may have been an issue with an incorrect canonical tag. Will pm you if it is not that.
Regards
Ron

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2