XML Sitemaps Generator

Author Topic: internal server error after moving host  (Read 7271 times)

simon2

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
internal server error after moving host
« on: July 29, 2012, 02:16:08 PM »
Hi

I am using version 6 of the unlimited standalone generator but cannot get it to crawl my site after moving to another hosting account - the exact same vps setup with the same host.

I have re-installed the generator but everytime I run the crawl I get an internal server error page within the crawl page. The error log is showing the following...

[29-Jul-2012 14:07:50 UTC] PHP Warning:  flush() [<a href='function.flush'>function.flush</a>]: A session is active. You cannot change the session module's ini settings at this time in /home/ukinsura/public_html/generator/pages/page-crawlproc.inc.php on line 212

I have set the correct permissions and got the host to increase the php memory from 32m to 64m.

Any advice would be a big help.

Thanks
« Last Edit: July 29, 2012, 02:40:13 PM by simon2 »

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: internal server error after moving host
« Reply #1 on: July 30, 2012, 06:35:04 AM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

simon2

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Re: internal server error after moving host
« Reply #2 on: July 30, 2012, 10:45:13 AM »
Hi

I have increased the memory limit to 256m and max execution times from 30s to 120s but still see the error.

However, the daily cron I have set does appear to have run the crawl successfully. But I still cannot get it to work within a browser.

Thanks

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10624
Re: internal server error after moving host
« Reply #3 on: July 31, 2012, 10:31:58 AM »
Hello,

please let me know your generator URL/login in private message to check this.

> However, the daily cron I have set does appear to have run the crawl successfully.

I think it's ok then, since it's recommended to run it via cron task anyway.
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

simon2

  • Registered Customer
  • Approved member
  • *
  • Posts: 9
Re: internal server error after moving host
« Reply #4 on: July 31, 2012, 11:26:16 AM »
Hi, thanks for your help. It is fixed now and was caused by a server Mod_Sec rule.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2