XML Sitemaps Generator

Author Topic: php 5.4 compatibility  (Read 8462 times)

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
php 5.4 compatibility
« on: November 08, 2012, 04:11:23 PM »
Hi,

when i run sitemap generator i get an error and the generator stops. Normaly after about 200 entries.

The error says i should take a look into the log file and ask the provider. The provider says, maybe the generator isn't fully php 5.4 compatible.

[Thu Nov 08 12:24:22 2012] [warn] [client my ip] mod_fcgid: read data timeout in 40 seconds, referer: [external links are visible to admins only]
[Thu Nov 08 12:24:22 2012] [error] [client my ip] Premature end of script headers: php54-fcgi-starter, referer: [external links are visible to admins only]

So my question is. Is the generator fully php5.4 compatible?
Are there any other ways how i can solve the problem?

Thanks in advance.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: php 5.4 compatibility
« Reply #1 on: November 08, 2012, 07:52:43 PM »
Hello,

it looks like your server configuration doesn't allow to run the script long enough to create full sitemap. Please try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or contact hosting support regarding this.
 
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

989

  • Registered Customer
  • Jr. Member
  • *
  • Posts: 27
Re: php 5.4 compatibility
« Reply #2 on: November 08, 2012, 09:18:42 PM »
Hi,

makes no difference if i use php 5.3.x ,or php 5.4.8.
Still the same fault.

Put memory to 128 MB (which is the maximum for my webspace). Still got the error.

This time the log says:
[Thu Nov 08 21:55:18 2012] [warn] [client my ip] mod_fcgid: read data timeout in 40 seconds, referer: [external links are visible to admins only]
[Thu Nov 08 21:55:18 2012] [error] [client my ip] Premature end of script headers: php54-fcgi-starter, referer: [external links are visible to admins only]
[Thu Nov 08 21:56:47 2012] [warn] [client my ip] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: [external links are visible to admins only]
[Thu Nov 08 21:56:47 2012] [warn] [client my ip] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: [external links are visible to admins only]

Any ideas?

Thanks in advance.

XML-Sitemaps Support

  • Administrator
  • Hero Member
  • *****
  • Posts: 10621
Re: php 5.4 compatibility
« Reply #3 on: November 09, 2012, 04:58:51 PM »
You need to increase max_executuion_time and CGI timeouts:
>.. read data timeout in 40 seconds
Oleg Ignatiuk
www.xml-sitemaps.com
Send me a Private Message

For maximum exposure and traffic for your web site check out our additional SEO Services.

 

SMF 2.0.12 | SMF © 2014, Simple Machines
XHTML RSS WAP2